add nocatsplash depend on glib
[openwrt/openwrt.git] / openwrt / package / Makefile
index 429741d39d1f0799baff1c31d952d2a83c15b4df..9ba234597e3b770bf0799f4ee650eda47a3a6b7f 100644 (file)
@@ -3,6 +3,7 @@ include $(TOPDIR)/rules.mk
 
 package-y:=openwrt
 package-$(BR2_PACKAGE_ARPTABLES) += arptables
+package-$(BR2_PACKAGE_ARPWATCH) += arpwatch
 package-$(BR2_PACKAGE_BRIDGE) += bridge
 package-$(BR2_PACKAGE_BUSYBOX) += busybox
 package-$(BR2_PACKAGE_CHILLISPOT) += chillispot
@@ -13,6 +14,7 @@ package-$(BR2_PACKAGE_DNSMASQ) += dnsmasq
 package-$(BR2_PACKAGE_EBTABLES) += ebtables
 package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
 package-$(BR2_PACKAGE_FPING) += fping
+package-$(BR2_PACKAGE_GLIB) += glib
 package-$(BR2_PACKAGE_GMP) += gmp
 package-$(BR2_PACKAGE_HASERL) += haserl
 package-$(BR2_PACKAGE_IPTABLES) += iptables
@@ -25,6 +27,7 @@ package-$(BR2_PACKAGE_MATRIXSSL) += matrixssl
 package-$(BR2_PACKAGE_MICROPERL) += microperl
 package-$(BR2_PACKAGE_NCURSES) += ncurses
 package-$(BR2_PACKAGE_NFSD) += nfs-server
+package-$(BR2_PACKAGE_NOCATSPLASH) += nocatsplash
 package-$(BR2_PACKAGE_OPENSSL) += openssl
 package-$(BR2_PACKAGE_OPENNTPD) += openntpd
 package-$(BR2_PACKAGE_OPENVPN) += openvpn
@@ -51,6 +54,8 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m)) linux-clean
 compile: $(patsubst %,%-compile,$(package-y) $(package-m))
 install: $(patsubst %,%-install,$(package-y))
 
+nocatsplash-compile: glib-compile
+arpwatch-compile: libpcap-compile
 tcpdump-compile: libpcap-compile
 dropbear-compile: zlib-compile
 openssl-compile: zlib-compile