rewrite of the network scripts and configuration
[openwrt/svn-archive/archive.git] / openwrt / package / ppp / Makefile
index 55986f95c05bff9b5506317e121f863ee07a0c91..e49b610c36b49e878e2d3323b3c98c47c879d890 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -15,7 +21,7 @@ PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/ppp
 SECTION:=net
@@ -89,6 +95,8 @@ define Build/Compile
 endef
 
 define Package/ppp/install
+       install -d -m0755 $(1)/lib/network
+       install -m0755 ./files/ppp.sh $(1)/lib/network/
        install -d -m0755 $(1)/etc/ppp
        install -m0600 ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
        install -m0644 ./files/etc/ppp/filter $(1)/etc/ppp/
@@ -104,19 +112,19 @@ define Package/ppp/install
 endef
        
 define Package/ppp-mod-pppoa/install
+       install -d -m0755 $(1)/lib/network
+       install -m0755 ./files/pppoa.sh $(1)/lib/network/
        install -d -m0755 $(1)/usr/lib/pppd/$(PKG_VERSION)
        install -m0755 $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/pppoatm.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
-       install -d -m0755 $(1)/sbin
-       install -m0755 ./files/ifup.pppoa $(1)/sbin/
 endef
 
 define Package/ppp-mod-pppoe/install
+       install -d -m0755 $(1)/lib/network
+       install -m0755 ./files/pppoe.sh $(1)/lib/network/
        install -d -m0755 $(1)/usr/lib/pppd/$(PKG_VERSION)
        install -m0755 $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/rp-pppoe.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
-       install -d -m0755 $(1)/sbin
-       install -m0755 ./files/ifup.pppoe $(1)/sbin/
 endef
 
 define Package/ppp-mod-radius/install
@@ -145,7 +153,6 @@ endef
 define Package/pppstats/install
        install -d -m0755 $(1)/usr/sbin
        install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/pppstats $(1)/usr/sbin/
-       $(RSTRIP) $(1)
 endef
 
 $(eval $(call BuildPackage,ppp))