add target/download
[openwrt/openwrt.git] / openwrt / target / linux / image / squashfs.mk
index 00411c05e4b99e8ea818077f4e5456a524212461..e01766c0caba278cbc82822bf48337d36d46fce8 100644 (file)
@@ -1,27 +1,25 @@
-squashfs-prepare:
-       $(MAKE) -C squashfs prepare
+ifneq ($(CONFIG_BIG_ENDIAN),y)
+ENDIAN := le
+else
+ENDIAN := be
+endif
 
-squashfs-compile:
-       $(MAKE) -C squashfs compile
+squashfs-source: FORCE
+       $(MAKE) -C $(TOPDIR)/target/linux/image/squashfs source
+
+$(STAGING_DIR)/bin/mksquashfs-lzma:
+       $(MAKE) -C $(TOPDIR)/target/linux/image/squashfs compile
        
-squashfs-clean:
-       $(MAKE) -C squashfs clean
+squashfs-clean: FORCE
+       $(MAKE) -C $(TOPDIR)/target/linux/image/squashfs clean
        rm -f $(KDIR)/root.squashfs
 
-$(KDIR)/root.squashfs: install-prepare
-       @mkdir -p $(KDIR)/root/jffs
-       $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le
-
-squashfs-install: $(KDIR)/root.squashfs $(BOARD)-compile
-       $(TRACE) target/linux/image/$(BOARD)/install
-       $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
+define Image/mkfs/squashfs
+       @mkdir -p $(BUILD_DIR)/root/jffs
+       $(STAGING_DIR)/bin/mksquashfs-lzma $(BUILD_DIR)/root $(KDIR)/root.squashfs -nopad -noappend -root-owned -$(ENDIAN)
+       $(call Image/Build,squashfs)
+endef
 
-squashfs-install-ib:
-       mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
-       cp $(STAGING_DIR)/bin/mksquashfs-lzma $(IB_DIR)/staging_dir_$(ARCH)/bin
-       
-prepare: squashfs-prepare
-compile: squashfs-compile
-install: squashfs-install
-install-ib: squashfs-install-ib
-clean: squashfs-clean
+FILESYSTEMS += squashfs
+compile-targets: $(STAGING_DIR)/bin/mksquashfs-lzma
+clean-targets: squashfs-clean