add target/download
[openwrt/openwrt.git] / openwrt / target / linux / image / squashfs.mk
index 7fe972a45efcce0a887ff228b64cf35b24589c6c..e01766c0caba278cbc82822bf48337d36d46fce8 100644 (file)
@@ -1,37 +1,25 @@
-endian := le
-
-ifeq ($(ARCH),mips)
-       endian := be
+ifneq ($(CONFIG_BIG_ENDIAN),y)
+ENDIAN := le
+else
+ENDIAN := be
 endif
 
-squashfs-prepare:
-       $(MAKE) -C squashfs prepare $(MAKE_TRACE)
+squashfs-source: FORCE
+       $(MAKE) -C $(TOPDIR)/target/linux/image/squashfs source
 
-squashfs-compile: prepare-targets
-       $(MAKE) -C squashfs compile $(MAKE_TRACE)
+$(STAGING_DIR)/bin/mksquashfs-lzma:
+       $(MAKE) -C $(TOPDIR)/target/linux/image/squashfs compile
        
-squashfs-clean:
-       $(MAKE) -C squashfs clean $(MAKE_TRACE)
+squashfs-clean: FORCE
+       $(MAKE) -C $(TOPDIR)/target/linux/image/squashfs clean
        rm -f $(KDIR)/root.squashfs
 
-$(KDIR)/root.squashfs: install-prepare
-       @mkdir -p $(KDIR)/root/jffs
-       $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -$(endian) $(MAKE_TRACE)
-       
-ifeq ($(IB),)
-squashfs-install: compile-targets $(BOARD)-compile
-endif
+define Image/mkfs/squashfs
+       @mkdir -p $(BUILD_DIR)/root/jffs
+       $(STAGING_DIR)/bin/mksquashfs-lzma $(BUILD_DIR)/root $(KDIR)/root.squashfs -nopad -noappend -root-owned -$(ENDIAN)
+       $(call Image/Build,squashfs)
+endef
 
-squashfs-install: $(KDIR)/root.squashfs
-       $(TRACE) target/linux/image/$(BOARD)/install
-       $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
-
-squashfs-install-ib: compile-targets
-       mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
-       cp $(STAGING_DIR)/bin/mksquashfs-lzma $(IB_DIR)/staging_dir_$(ARCH)/bin
-       
-prepare-targets: squashfs-prepare
-compile-targets: squashfs-compile
-install-targets: squashfs-install
-install-ib: squashfs-install-ib
-clean: squashfs-clean
+FILESYSTEMS += squashfs
+compile-targets: $(STAGING_DIR)/bin/mksquashfs-lzma
+clean-targets: squashfs-clean