only use --wildcards for gnu tar
[openwrt/openwrt.git] / openwrt / toolchain / kernel-headers / Makefile
index 7b5c06c7819a37f43b96143d38b15194ac31a386..3e2cd2ae8678074d1956870660dd8aaf9814c14a 100644 (file)
@@ -29,9 +29,10 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
        -e 's/armeb/arm/' \
 )
 
+
 define Build/Prepare
        mkdir -p $(TOOLCHAIN_BUILD_DIR)
-       bzcat $(DL_DIR)/$(PKG_SOURCE) | tar --wildcards -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
+       bzcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
                linux-$(PKG_VERSION)/include \
                linux-$(PKG_VERSION)/Makefile \
                linux-$(PKG_VERSION)/Rules.make \