explicitely disable a bunch of package on ar7 until we properly detect pci & usb...
[openwrt/openwrt.git] / package / alsa / Makefile
index 347ef76276a8f0c11e6599796fedbdd9beca5d81..8dc7b871a494f132bbe99794bad75dfef10aab4f 100644 (file)
@@ -16,9 +16,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
 PKG_MD5SUM:=4cff99be4b225e96663fbd61cabe3182
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,7 +23,6 @@ define KernelPackage/alsa
   SUBMENU:=Other modules
   DEPENDS:=@USB_SUPPORT @LINUX_2_4
   TITLE:=Advanced Linux Sound Architecture
-  DESCRIPTION:=
   FILES:=$(PKG_BUILD_DIR)/modules/*.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD=$(call AutoLoad,70,$(shell cat ./files/alsa.modules))
 endef
@@ -52,6 +48,7 @@ CONFIGURE_VARS:= \
 CONFIGURE_ARGS:= \
        --with-build="$(LINUX_DIR)" \
        --with-kernel="$(LINUX_DIR)" \
+       --with-cross="$(KERNEL_CROSS)" \
        --with-redhat=no \
        --with-suse=no \
        --with-oss=yes \