add an optional config option for stripping all unnecessary symbol exports from the...
[openwrt/openwrt.git] / package / base-files / Makefile
index 6bec4184fab7b688f4e13fc485bc3f595118f220..6901829f29290604942631537d1ca83667a5cad9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=24
+PKG_RELEASE:=25
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
@@ -247,6 +247,10 @@ define Package/libc/install
 $(call Package/$(LIBC)/install,$1)
 endef
 
+define Package/libc/install_lib
+       $(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
+endef
+
 define Package/libpthread/install
        $(INSTALL_DIR) $(1)/lib
        $(CP) $(TOOLCHAIN_DIR)/lib/libpthread.so.* $(1)/lib/