GRE: Tos support
[openwrt/staging/chunkeey.git] / package / base-files / Makefile
index d0366eeab3315fbca079ca156cb3e13d434b605f..83385143cfca8b6f400b32f100e3afbbbc67e2e5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2013 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 # Copyright (C) 2010 Vertical Communications
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=151
+PKG_RELEASE:=156
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
@@ -28,7 +28,7 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+netifd +libc +procd
+  DEPENDS:=+netifd +libc +procd +jsonfilter
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
@@ -110,8 +110,11 @@ define Package/base-files/install
 
        $(VERSION_SED) \
                $(1)/etc/banner \
-               $(1)/etc/openwrt_version \
-               $(1)/etc/openwrt_release
+               $(1)/etc/openwrt_version
+
+       $(VERSION_SED_SCRIPT) \
+               $(1)/etc/openwrt_release \
+               $(1)/etc/device_info
 
        mkdir -p $(1)/CONTROL
        mkdir -p $(1)/dev