tfa-layerscape: bump to LSDK-21.08
[openwrt/openwrt.git] / package / boot / tfa-layerscape / patches / 003-plat-nxp-tools-fix-create_pbl-and-byte_swap-host-bui.patch
index 2b19d53c7146d040c8c6462f1ca4f5aaf34015a4..167549d55b52759db0455c03da349daaffee9b7e 100644 (file)
@@ -1,19 +1,19 @@
 From 8a458876013991fe2f288bbe4694264b16c3b9e9 Mon Sep 17 00:00:00 2001
 From: Biwen Li <biwen.li@nxp.com>
 Date: Fri, 26 Jul 2019 15:44:10 +0800
-Subject: [PATCH 3/3] plat/nxp/tools: fix create_pbl and byte_swap host build
+Subject: [PATCH 3/3] tools/nxp: fix create_pbl and byte_swap host build
 
 Not compile create_pbl and byte_swap in the process of cross compilation
 
 Signed-off-by: Biwen Li <biwen.li@nxp.com>
 ---
plat/nxp/tools/pbl_ch2.mk | 3 ---
plat/nxp/tools/pbl_ch3.mk | 5 -----
tools/nxp/pbl_ch2.mk | 3 ---
tools/nxp/pbl_ch3.mk | 5 -----
  2 files changed, 8 deletions(-)
 
---- a/plat/nxp/tools/pbl_ch2.mk
-+++ b/plat/nxp/tools/pbl_ch2.mk
-@@ -20,8 +20,6 @@ ifeq ($(RCW),"")
+--- a/tools/nxp/pbl_ch2.mk
++++ b/tools/nxp/pbl_ch2.mk
+@@ -19,8 +19,6 @@ ifeq ($(RCW),"")
  else
        # Generate header for bl2.bin
        $(Q)$(CST_DIR)/create_hdr_isbc --in ${BUILD_PLAT}/bl2.bin --out ${BUILD_PLAT}/hdr_bl2 ${BL2_INPUT_FILE}
@@ -22,7 +22,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        # Add bl2.bin to RCW
        ${CREATE_PBL} -r ${RCW} -i ${BUILD_PLAT}/bl2.bin -b ${BOOT_MODE} -c ${SOC_NUM} -d ${BL2_BASE} -e ${BL2_BASE}\
                        -o ${BUILD_PLAT}/bl2_${BOOT_MODE}.pbl ;\
-@@ -43,7 +41,6 @@ ifeq ($(RCW),"")
+@@ -42,7 +40,6 @@ ifeq ($(RCW),"")
        ${Q}echo "Platform ${PLAT} requires rcw file. Please set RCW to point to the right RCW file for boot mode ${BOOT_MODE}"
  else
        # -a option appends the image for Chassis 3 devices in case of non secure boot
@@ -30,9 +30,9 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        ${CREATE_PBL} -r ${RCW} -i ${BUILD_PLAT}/bl2.bin -b ${BOOT_MODE} -c ${SOC_NUM} -d ${BL2_BASE} -e ${BL2_BASE} \
        -o ${BUILD_PLAT}/bl2_${BOOT_MODE}.pbl ;
  # Swapping of RCW is required for QSPi Chassis 2 devices
---- a/plat/nxp/tools/pbl_ch3.mk
-+++ b/plat/nxp/tools/pbl_ch3.mk
-@@ -27,9 +27,6 @@ else
+--- a/tools/nxp/pbl_ch3.mk
++++ b/tools/nxp/pbl_ch3.mk
+@@ -26,9 +26,6 @@ else
        # Generate header for bl2.bin
        $(Q)$(CST_DIR)/create_hdr_isbc --in ${BUILD_PLAT}/bl2.bin --out ${BUILD_PLAT}/hdr_bl2 ${BL2_INPUT_FILE}
  
@@ -42,7 +42,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        # Add Block Copy command for bl2.bin to RCW
        ${CREATE_PBL} -r ${RCW} -i ${BUILD_PLAT}/bl2.bin -b ${BOOT_MODE} -c ${SOC_NUM} -d ${BL2_BASE} -e ${BL2_BASE}\
                        -o ${BUILD_PLAT}/bl2_${BOOT_MODE}.pbl -f ${BL2_SRC_OFFSET};\
-@@ -57,8 +54,6 @@ else  #SECURE_BOOT
+@@ -56,8 +53,6 @@ else  #SECURE_BOOT
  ifeq ($(RCW),"")
        ${Q}echo "Platform ${PLAT} requires rcw file. Please set RCW to point to the right RCW file for boot mode ${BOOT_MODE}"
  else