uboot-envtools: Add TARGET_LDFLAGS to fix PIE and RELRO
[openwrt/openwrt.git] / package / boot / uboot-envtools / patches / 001-compile.patch
index f7ec9130d6f49ac9895f10e593530a241b2c316d..098772f557dfa3e2a61bbaf970281ded95c11027 100644 (file)
@@ -1,12 +1,15 @@
 --- a/tools/env/Makefile
 +++ b/tools/env/Makefile
-@@ -10,6 +10,10 @@
+@@ -10,6 +10,13 @@
  # with "CC" here for the maximum code reuse of scripts/Makefile.host.
  override HOSTCC = $(CC)
  
 +ifneq ($(TARGET_CFLAGS),)
 +HOSTCFLAGS = $(TARGET_CFLAGS)
 +endif
++ifneq ($(TARGET_LDFLAGS),)
++HOSTLDFLAGS = $(TARGET_LDFLAGS)
++endif
 +
  # Compile for a hosted environment on the target
  HOST_EXTRACFLAGS  = $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \