package/grub: revert accidental/unessesery grub commit
[openwrt/openwrt.git] / package / bridge-utils / Makefile
index 6b249ac8683d8ae807dc0880900b4ea28b2e3a33..0b6eaecb8752755f375f33feea76929c9150073a 100644 (file)
@@ -1,21 +1,20 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=bridge-utils
-PKG_VERSION:=1.0.6
 PKG_RELEASE:=1
+PKG_SOURCE_URL:=@SF/bridge
+PKG_VERSION:=1.4
+PKG_MD5SUM:=0182fcac3a2b307113bbec34e5f1c673
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/bridge
-PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,13 +22,26 @@ define Package/bridge
   SECTION:=net
   CATEGORY:=Base system
   TITLE:=Ethernet bridging configuration utility
-  DESCRIPTION:=\
-       Manage ethernet bridging: a way to connect networks together to \\\
-       form a larger network.
   URL:=http://bridge.sourceforge.net/
 endef
 
-CONFIGURE_ARGS += --with-linux-headers="$(LINUX_DIR)"
+define Package/bridge/description
+ Manage ethernet bridging: a way to connect networks together to 
+ form a larger network.
+endef
+
+CONFIGURE_ARGS += \
+       --with-linux-headers="$(LINUX_DIR)" \
+
+define Build/Prepare
+$(call Build/Prepare/Default)
+       ( cd $(PKG_BUILD_DIR) ; \
+               [ -f ./configure ] || { \
+                       ln -sf configure.in configure.ac ; \
+                       autoconf ; \
+               } \
+       )
+endef
 
 define Package/bridge/install
        $(INSTALL_DIR) $(1)/usr/sbin