valgrind: update to the latest version, fix build issues on ARM
[openwrt/staging/jogo.git] / package / devel / valgrind / Makefile
index c4f36979e01d2abcf21d84ada58c5b79bd36b5a2..04d06d91a6847db253bef4f3faedd60ac655dd56 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,25 +8,29 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=valgrind
-PKG_VERSION:=3.8.0
+PKG_VERSION:=3.11.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://valgrind.org/downloads/
-PKG_MD5SUM:=ec04dfd1256307432b2a7b520398c526
+PKG_MD5SUM:=6c396271a8c1ddd5a6fb9abe714ea1e8a86fce85b30ab26b4266aeb4c2413b42
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=GPL-2.0+
 
 PKG_FIXUP = autoreconf
 PKG_INSTALL := 1
+PKG_BUILD_PARALLEL := 1
+PKG_USE_MIPS16:=0
+PKG_SSP:=0
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 define Package/valgrind
-  SECTION:=utils
-  CATEGORY:=Utilities
-  DEPENDS:=@mips||mipsel||i386||powerpc||TARGET_omap4 +libpthread +librt
+  SECTION:=devel
+  CATEGORY:=Development
+  DEPENDS:=@mips||mipsel||i386||x86_64||powerpc||arm_v7 +libpthread +librt
   TITLE:=debugging and profiling tools for Linux
   URL:=http://www.valgrind.org
 endef
@@ -75,20 +79,31 @@ define Package/valgrind/description
        to speed up and reduce memory use of your programs.
 endef
 
-CPU := $(patsubst x86,i386,$(LINUX_KARCH))
+CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(patsubst um,$(ARCH),$(LINUX_KARCH))))
 
 CONFIGURE_VARS += \
        UNAME_R=$(LINUX_VERSION)
 
+ifeq ($(ARCH),x86_64)
+       CONFIGURE_ARGS += \
+               --enable-only64bit
+       BITS := 64bit
+else
+       CONFIGURE_ARGS += \
+               --enable-only32bit
+       BITS := 32bit
+endif
+
 CONFIGURE_ARGS += \
-       --enable-only32bit \
        --enable-tls \
        --without-x \
+       --without-mpicc \
        --without-uiout \
        --disable-valgrindmi \
        --disable-tui \
        --disable-valgrindtk \
-       --without-included-gettext
+       --without-included-gettext \
+       --with-pagesize=4 \
 
 define Package/valgrind/install        
        $(INSTALL_DIR) $(1)/usr/bin
@@ -99,8 +114,8 @@ define Package/valgrind/install
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/none-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_core*.so \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(CPU)-*.xml \
-               $(PKG_INSTALL_DIR)/usr/lib/valgrind/32bit-core*.xml \
-               $(PKG_INSTALL_DIR)/usr/lib/valgrind/32bit-linux*.xml \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-core*.xml \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-linux*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/memcheck-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_memcheck*.so \
                $(1)/usr/lib/valgrind/