valgrind: Update to version 3.15.0
[openwrt/staging/dedeckeh.git] / package / devel / valgrind / Makefile
index e2c7f6728069283fcf12588099eade5eb283eacf..0c5b0cffd45cc6a1aeae2cd5cff899d283f94dec 100644 (file)
@@ -8,20 +8,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=valgrind
-PKG_VERSION:=3.10.0
+PKG_VERSION:=3.15.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://valgrind.org/downloads/
-PKG_MD5SUM:=7c311a72a20388aceced1aa5573ce970
+PKG_SOURCE_URL:=http://sourceware.org/pub/valgrind/
+PKG_HASH:=417c7a9da8f60dd05698b3a7bc6002e4ef996f14c13f0ff96679a16873e78ab1
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=GPL-2.0+
+PKG_CPE_ID:=cpe:/a:valgrind:valgrind
 
 PKG_FIXUP = autoreconf
 PKG_INSTALL := 1
 PKG_BUILD_PARALLEL := 1
 PKG_USE_MIPS16:=0
+PKG_SSP:=0
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -83,7 +85,7 @@ CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(patsubst um,$(ARCH),$(LINUX
 CONFIGURE_VARS += \
        UNAME_R=$(LINUX_VERSION)
 
-ifeq ($(ARCH),x86_64)
+ifeq ($(CONFIG_ARCH_64BIT),y)
        CONFIGURE_ARGS += \
                --enable-only64bit
        BITS := 64bit
@@ -101,7 +103,8 @@ CONFIGURE_ARGS += \
        --disable-valgrindmi \
        --disable-tui \
        --disable-valgrindtk \
-       --without-included-gettext
+       --without-included-gettext \
+       --with-pagesize=4 \
 
 define Package/valgrind/install        
        $(INSTALL_DIR) $(1)/usr/bin
@@ -111,12 +114,17 @@ define Package/valgrind/install
                ./files/default.supp \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/none-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_core*.so \
-               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(CPU)-*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-core*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-linux*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/memcheck-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_memcheck*.so \
                $(1)/usr/lib/valgrind/
+
+ifneq ($(ARCH),aarch64)
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(CPU)-*.xml \
+               $(1)/usr/lib/valgrind/
+endif
 endef
 
 define Package/valgrind-cachegrind/install