rename unvram to nvram
[openwrt/openwrt.git] / package / hostap-driver / Makefile
index 5be9f9eb59dda12cff2ce215472656c03a49a926..c77f56ed0423b11152c97a6ff85cab087bfeb4ed 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -46,7 +45,7 @@ endef
 define KernelPackage/hostap
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP support for Prism2/2.5/3
-  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211
+  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211 +wireless-tools
   KCONFIG:=CONFIG_HOSTAP
 endef
 
@@ -174,6 +173,15 @@ else
   endef
 endif
 
+define KernelPackage/hostap-pci/install
+       $(INSTALL_DIR) $(1)/lib/wifi
+       $(INSTALL_DATA) ./files/lib/wifi/hostap.sh $(1)/lib/wifi
+endef
+
+define KernelPackage/hostap-plx/install
+       $(INSTALL_DIR) $(1)/lib/wifi
+       $(INSTALL_DATA) ./files/lib/wifi/hostap.sh $(1)/lib/wifi
+endef
 
 $(eval $(call KernelPackage,hostap))
 $(eval $(call KernelPackage,hostap-cs))