refresh all package patches in the buildroot using quilt
[openwrt/staging/mkresin.git] / package / isakmpd / patches / 020-standardize.patch
index d6c5e87b5bf76146f7ae4371a9dc226c776a18da..435782b6376c3d47036f6281128d71e2ba402826 100644 (file)
@@ -1,7 +1,16 @@
-diff -urN isakmpd/GNUmakefile isakmpd.new/GNUmakefile
---- isakmpd/GNUmakefile        2004-01-16 13:36:32.000000000 +0100
-+++ isakmpd.new/GNUmakefile    2006-09-03 17:33:03.000000000 +0200
-@@ -238,3 +238,16 @@
+Index: isakmpd-20041012.orig/GNUmakefile
+===================================================================
+--- isakmpd-20041012.orig.orig/GNUmakefile     2007-06-04 13:22:39.283883224 +0200
++++ isakmpd-20041012.orig/GNUmakefile  2007-06-04 13:22:39.722816496 +0200
+@@ -168,7 +168,6 @@
+ X509=         x509.c
+ CFLAGS+=      -DUSE_LIBCRYPTO
+ LDADD+=               -lcrypto
+-DPADD+=               ${LIBCRYPTO}
+ endif
+ ifdef USE_RAWKEY
+@@ -242,3 +241,16 @@
  
  realcleandepend:
        rm -f .depend tags
@@ -18,9 +27,10 @@ diff -urN isakmpd/GNUmakefile isakmpd.new/GNUmakefile
 +      $(INSTALL) $(INSTALL_OPTS) -m 444 isakmpd.8 $(DESTDIR)$(MANDIR)/man8
 +      -mkdir -p $(DESTDIR)$(MANDIR)/man5
 +      $(INSTALL) $(INSTALL_OPTS) -m 444 isakmpd.conf.5 isakmpd.policy.5 $(DESTDIR)$(MANDIR)/man5
-diff -urN isakmpd/samples/Makefile isakmpd.new/samples/Makefile
---- isakmpd/samples/Makefile   2003-06-03 16:39:50.000000000 +0200
-+++ isakmpd.new/samples/Makefile       2006-09-03 17:07:24.000000000 +0200
+Index: isakmpd-20041012.orig/samples/Makefile
+===================================================================
+--- isakmpd-20041012.orig.orig/samples/Makefile        2007-06-04 13:22:39.015923960 +0200
++++ isakmpd-20041012.orig/samples/Makefile     2007-06-04 13:22:39.722816496 +0200
 @@ -26,7 +26,7 @@
  #
  
@@ -30,10 +40,10 @@ diff -urN isakmpd/samples/Makefile isakmpd.new/samples/Makefile
  
  # The mkdir below is for installation on OpenBSD pre 2.7
  install:
-
-diff -urN isakmp.old/sysdep/linux/GNUmakefile.sysdep isakmp.dev/sysdep/linux/GNUmakefile.sysdep
---- isakmp.old/sysdep/linux/GNUmakefile.sysdep 2006-09-07 13:49:20.000000000 +0200
-+++ isakmp.dev/sysdep/linux/GNUmakefile.sysdep 2006-09-07 13:51:41.000000000 +0200
+Index: isakmpd-20041012.orig/sysdep/linux/GNUmakefile.sysdep
+===================================================================
+--- isakmpd-20041012.orig.orig/sysdep/linux/GNUmakefile.sysdep 2007-06-04 13:22:39.291882008 +0200
++++ isakmpd-20041012.orig/sysdep/linux/GNUmakefile.sysdep      2007-06-04 13:22:39.722816496 +0200
 @@ -25,18 +25,18 @@
  # THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  #
@@ -57,20 +67,10 @@ diff -urN isakmp.old/sysdep/linux/GNUmakefile.sysdep isakmp.dev/sysdep/linux/GNU
  
  FEATURES=     debug tripledes blowfish cast ec aggressive x509 policy
  FEATURES+=    dpd nat_traversal isakmp_cfg des aes
-diff -ruN isakmpd-20041012.orig/GNUmakefile isakmpd-20041012.new/GNUmakefile
---- isakmpd-20041012.orig/GNUmakefile  2006-12-16 22:41:26.000000000 +0100
-+++ isakmpd-20041012.new/GNUmakefile   2006-12-16 22:48:27.000000000 +0100
-@@ -169,7 +169,6 @@
- X509=         x509.c
- CFLAGS+=      -DUSE_LIBCRYPTO
- LDADD+=               -lcrypto
--DPADD+=               ${LIBCRYPTO}
- endif
- ifdef USE_RAWKEY
-diff -ruN isakmpd-20041012.orig/Makefile isakmpd-20041012.new/Makefile
---- isakmpd-20041012.orig/Makefile     2004-10-12 23:25:52.000000000 +0200
-+++ isakmpd-20041012.new/Makefile      2006-12-16 22:46:48.000000000 +0100
+Index: isakmpd-20041012.orig/Makefile
+===================================================================
+--- isakmpd-20041012.orig.orig/Makefile        2007-06-04 13:22:39.028921984 +0200
++++ isakmpd-20041012.orig/Makefile     2007-06-04 13:22:39.723816344 +0200
 @@ -147,7 +147,6 @@
  .ifdef USE_LIBCRYPTO
  CFLAGS+=      -DUSE_LIBCRYPTO
@@ -79,9 +79,10 @@ diff -ruN isakmpd-20041012.orig/Makefile isakmpd-20041012.new/Makefile
  .endif
  
  .ifdef USE_LIBDES
-diff -ruN isakmpd-20041012.orig/apps/certpatch/Makefile isakmpd-20041012.new/apps/certpatch/Makefile
---- isakmpd-20041012.orig/apps/certpatch/Makefile      2004-10-12 23:25:52.000000000 +0200
-+++ isakmpd-20041012.new/apps/certpatch/Makefile       2006-12-16 22:48:58.000000000 +0100
+Index: isakmpd-20041012.orig/apps/certpatch/Makefile
+===================================================================
+--- isakmpd-20041012.orig.orig/apps/certpatch/Makefile 2007-06-04 13:22:39.035920920 +0200
++++ isakmpd-20041012.orig/apps/certpatch/Makefile      2007-06-04 13:22:39.723816344 +0200
 @@ -40,7 +40,6 @@
  .PATH:                ${TOPSRC} ${TOPSRC}/sysdep/${OS} ${TOPOBJ}
  CFLAGS+=      -I${TOPSRC} -I${TOPSRC}/sysdep/${OS} -I${TOPOBJ} -Wall
@@ -90,9 +91,10 @@ diff -ruN isakmpd-20041012.orig/apps/certpatch/Makefile isakmpd-20041012.new/app
  MAN=          certpatch.8
  
  .if ${FEATURES:Mgmp} == "gmp"
-diff -ruN isakmpd-20041012.orig/regress/crypto/Makefile isakmpd-20041012.new/regress/crypto/Makefile
---- isakmpd-20041012.orig/regress/crypto/Makefile      2004-10-12 23:25:52.000000000 +0200
-+++ isakmpd-20041012.new/regress/crypto/Makefile       2006-12-16 22:50:02.000000000 +0100
+Index: isakmpd-20041012.orig/regress/crypto/Makefile
+===================================================================
+--- isakmpd-20041012.orig.orig/regress/crypto/Makefile 2007-06-04 13:22:39.041920008 +0200
++++ isakmpd-20041012.orig/regress/crypto/Makefile      2007-06-04 13:22:39.723816344 +0200
 @@ -13,7 +13,7 @@
                -DUSE_TRIPLEDES -DUSE_CAST -DUSE_BLOWFISH -DUSE_DES \
                -DUSE_AES
@@ -102,9 +104,10 @@ diff -ruN isakmpd-20041012.orig/regress/crypto/Makefile isakmpd-20041012.new/reg
  NOMAN=
  DEBUG=                -g
  
-diff -ruN isakmpd-20041012.orig/regress/dh/Makefile isakmpd-20041012.new/regress/dh/Makefile
---- isakmpd-20041012.orig/regress/dh/Makefile  2004-10-12 23:25:52.000000000 +0200
-+++ isakmpd-20041012.new/regress/dh/Makefile   2006-12-16 22:49:25.000000000 +0100
+Index: isakmpd-20041012.orig/regress/dh/Makefile
+===================================================================
+--- isakmpd-20041012.orig.orig/regress/dh/Makefile     2007-06-04 13:22:39.048918944 +0200
++++ isakmpd-20041012.orig/regress/dh/Makefile  2007-06-04 13:22:39.726815888 +0200
 @@ -15,7 +15,6 @@
                -DUSE_EC
  NOMAN=
@@ -113,9 +116,10 @@ diff -ruN isakmpd-20041012.orig/regress/dh/Makefile isakmpd-20041012.new/regress
  DEBUG=                -g
  
  .if ${FEATURES:Mgmp} == "gmp"
-diff -ruN isakmpd-20041012.orig/regress/group/Makefile isakmpd-20041012.new/regress/group/Makefile
---- isakmpd-20041012.orig/regress/group/Makefile       2004-10-12 23:25:52.000000000 +0200
-+++ isakmpd-20041012.new/regress/group/Makefile        2006-12-16 22:49:30.000000000 +0100
+Index: isakmpd-20041012.orig/regress/group/Makefile
+===================================================================
+--- isakmpd-20041012.orig.orig/regress/group/Makefile  2007-06-04 13:22:39.054918032 +0200
++++ isakmpd-20041012.orig/regress/group/Makefile       2007-06-04 13:22:39.727815736 +0200
 @@ -15,7 +15,6 @@
                -DUSE_EC
  NOMAN=
@@ -124,9 +128,10 @@ diff -ruN isakmpd-20041012.orig/regress/group/Makefile isakmpd-20041012.new/regr
  DEBUG=                -g
  
  .if ${FEATURES:Mgmp} == "gmp"
-diff -ruN isakmpd-20041012.orig/regress/rsakeygen/Makefile isakmpd-20041012.new/regress/rsakeygen/Makefile
---- isakmpd-20041012.orig/regress/rsakeygen/Makefile   2004-10-12 23:25:52.000000000 +0200
-+++ isakmpd-20041012.new/regress/rsakeygen/Makefile    2006-12-16 22:49:41.000000000 +0100
+Index: isakmpd-20041012.orig/regress/rsakeygen/Makefile
+===================================================================
+--- isakmpd-20041012.orig.orig/regress/rsakeygen/Makefile      2007-06-04 13:22:39.060917120 +0200
++++ isakmpd-20041012.orig/regress/rsakeygen/Makefile   2007-06-04 13:22:39.727815736 +0200
 @@ -62,7 +62,6 @@
  .ifdef USE_LIBCRYPTO
  CFLAGS+=      -DUSE_LIBCRYPTO
@@ -135,9 +140,10 @@ diff -ruN isakmpd-20041012.orig/regress/rsakeygen/Makefile isakmpd-20041012.new/
  .endif
  
  .if !defined (HAVE_DLOPEN) && !defined (USE_LIBCRYPTO)
-diff -ruN isakmpd-20041012.orig/regress/x509/Makefile isakmpd-20041012.new/regress/x509/Makefile
---- isakmpd-20041012.orig/regress/x509/Makefile        2004-10-12 23:25:52.000000000 +0200
-+++ isakmpd-20041012.new/regress/x509/Makefile 2006-12-16 22:49:49.000000000 +0100
+Index: isakmpd-20041012.orig/regress/x509/Makefile
+===================================================================
+--- isakmpd-20041012.orig.orig/regress/x509/Makefile   2007-06-04 13:22:39.068915904 +0200
++++ isakmpd-20041012.orig/regress/x509/Makefile        2007-06-04 13:22:39.727815736 +0200
 @@ -78,7 +78,6 @@
  X509=         x509.c
  CFLAGS+=      -DUSE_LIBCRYPTO