fix kmod-crypto-core compile with 2.6.30 (#5201)
[openwrt/openwrt.git] / package / kernel / Makefile
index d6364f12fe1ccc56a5aaec8194500a99e91f96a8..cde30683c3baa1dfc5cf259d2d04fc9b0ebde2fc 100644 (file)
@@ -1,10 +1,9 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -17,8 +16,6 @@ SCAN_DEPS=modules/*.mk
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
-  NF_KMOD:=1
-  include $(INCLUDE_DIR)/netfilter.mk
 endif
 
 define Build/Prepare
@@ -46,5 +43,5 @@ endef
 
 $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
-include $(TOPDIR)/target/linux/*/modules.mk
+-include $(TOPDIR)/target/linux/*/modules.mk
 include ./modules/*.mk