ath9k: fix more-data flag for buffered multicast packets
[openwrt/openwrt.git] / package / kernel / button-hotplug / Makefile
index 348ea13401163eab27b79d881a8b8adf0099b398..7b6aacfbf9be1a537f6e23a6ed591254d787597a 100644 (file)
@@ -10,19 +10,22 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=button-hotplug
 PKG_RELEASE:=3
+PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/button-hotplug
   SUBMENU:=Other modules
   TITLE:=Button Hotplug driver
+  DEPENDS:=+kmod-input-core
   FILES:=$(PKG_BUILD_DIR)/button-hotplug.ko
   AUTOLOAD:=$(call AutoLoad,30,button-hotplug,1)
   KCONFIG:=
 endef
 
 define KernelPackage/button-hotplug/description
-  Kernel module to generate button hotplug events
+  Kernel module to generate button uevent-s from input subsystem events.
+  If your device uses GPIO buttons, see gpio-button-hotplug.
 endef
 
 EXTRA_KCONFIG:= \
@@ -39,11 +42,6 @@ MAKE_OPTS:= \
        EXTRA_CFLAGS="$(EXTRA_CFLAGS)" \
        $(EXTRA_KCONFIG)
 
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
 define Build/Compile
        $(MAKE) -C "$(LINUX_DIR)" \
                $(MAKE_OPTS) \