kernel: remove useless AddDepends/hid abstraction
[openwrt/openwrt.git] / package / kernel / linux / modules / 001-depends.mk
index 445466fb3853cc4a485721b540ef6d58cd655705..57fc9abf73f3c0b43645f60a865cc15145c985c1 100644 (file)
@@ -5,14 +5,6 @@
 # See /LICENSE for more information.
 #
 
-define AddDepends/crc16
-  DEPENDS+= +kmod-lib-crc16 $(1)
-endef
-
-define AddDepends/hid
-  DEPENDS+= +kmod-hid $(1)
-endef
-
 define AddDepends/input
   DEPENDS+= +kmod-input-core $(1)
 endef
@@ -22,16 +14,11 @@ define AddDepends/nls
   DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
 endef
 
-
-define SetDepends/rfkill
-  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx) $(1)
-endef
-
 define AddDepends/rfkill
-  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_cns3xxx||TARGET_ixp4xx):kmod-rfkill $(1)
+  DEPENDS+= +USE_RFKILL:kmod-rfkill $(1)
 endef
 
 
 define AddDepends/rtc
-  DEPENDS+= @RTC_SUPPORT
+  DEPENDS+= @RTC_SUPPORT $(1)
 endef