kernel: backport patches for fq_codel queue memory limit support
[openwrt/openwrt.git] / package / kernel / linux / modules / block.mk
index e5222761620172a0b2107f4e950af876a072a88e..c83f98ddbd6463dc8b68eefab1a3fa54a657f996 100644 (file)
@@ -16,7 +16,7 @@ define KernelPackage/aoe
 endef
 
 define KernelPackage/aoe/description
 Kernel support for ATA over Ethernet
+ Kernel support for ATA over Ethernet
 endef
 
 $(eval $(call KernelPackage,aoe))
@@ -25,10 +25,12 @@ $(eval $(call KernelPackage,aoe))
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
-  DEPENDS:=@PCI_SUPPORT +kmod-scsi-core
+  DEPENDS:=@PCI_SUPPORT||TARGET_sunxi +kmod-scsi-core
   KCONFIG:=CONFIG_ATA
   FILES:=$(LINUX_DIR)/drivers/ata/libata.ko
-  AUTOLOAD:=$(call AutoLoad,21,libata,1)
+ifneq ($(wildcard $(LINUX_DIR)/drivers/ata/libahci.ko),)
+  FILES+=$(LINUX_DIR)/drivers/ata/libahci.ko
+endif
 endef
 
 $(eval $(call KernelPackage,ata-core))
@@ -44,19 +46,35 @@ define KernelPackage/ata-ahci
   TITLE:=AHCI Serial ATA support
   KCONFIG:=CONFIG_SATA_AHCI
   FILES:= \
-    $(LINUX_DIR)/drivers/ata/ahci.ko \
-    $(LINUX_DIR)/drivers/ata/libahci.ko
+    $(LINUX_DIR)/drivers/ata/ahci.ko
   AUTOLOAD:=$(call AutoLoad,41,libahci ahci,1)
   $(call AddDepends/ata)
 endef
 
 define KernelPackage/ata-ahci/description
- Support for AHCI Serial ATA controllers.
+ Support for AHCI Serial ATA controllers
 endef
 
 $(eval $(call KernelPackage,ata-ahci))
 
 
+define KernelPackage/ata-ahci-platform
+  TITLE:=AHCI Serial ATA Platform support
+  KCONFIG:=CONFIG_SATA_AHCI_PLATFORM
+  FILES:= \
+    $(LINUX_DIR)/drivers/ata/ahci_platform.ko \
+    $(LINUX_DIR)/drivers/ata/libahci_platform.ko
+  AUTOLOAD:=$(call AutoLoad,40,libahci libahci_platform ahci_platform,1)
+  $(call AddDepends/ata,@TARGET_ipq806x||TARGET_mvebu||TARGET_sunxi)
+endef
+
+define KernelPackage/ata-ahci-platform/description
+ Platform support for AHCI Serial ATA controllers
+endef
+
+$(eval $(call KernelPackage,ata-ahci-platform))
+
+
 define KernelPackage/ata-artop
   TITLE:=ARTOP 6210/6260 PATA support
   KCONFIG:=CONFIG_PATA_ARTOP
@@ -66,12 +84,31 @@ define KernelPackage/ata-artop
 endef
 
 define KernelPackage/ata-artop/description
- PATA support for ARTOP 6210/6260 host controllers.
+ PATA support for ARTOP 6210/6260 host controllers
 endef
 
 $(eval $(call KernelPackage,ata-artop))
 
 
+define KernelPackage/ata-imx
+  TITLE:=Freescale i.MX AHCI SATA support
+  DEPENDS:=@TARGET_imx6
+  KCONFIG:=\
+       CONFIG_AHCI_IMX \
+       CONFIG_SATA_AHCI_PLATFORM \
+       CONFIG_PATA_IMX=n
+  FILES:=$(LINUX_DIR)/drivers/ata/ahci_imx.ko
+  AUTOLOAD:=$(call AutoLoad,41,ahci_imx,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-imx/description
+ SATA support for the Freescale i.MX6 SoC's onboard AHCI SATA
+endef
+
+$(eval $(call KernelPackage,ata-imx))
+
+
 define KernelPackage/ata-marvell-sata
   TITLE:=Marvell Serial ATA support
   KCONFIG:=CONFIG_SATA_MV
@@ -87,6 +124,22 @@ endef
 $(eval $(call KernelPackage,ata-marvell-sata))
 
 
+define KernelPackage/ata-mvebu-ahci
+  TITLE:=Marvell EBU AHCI support
+  DEPENDS:=@TARGET_mvebu +kmod-ata-ahci-platform
+  KCONFIG:=CONFIG_AHCI_MVEBU
+  FILES:=$(LINUX_DIR)/drivers/ata/ahci_mvebu.ko
+  AUTOLOAD:=$(call AutoLoad,41,ahci_mvebu,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-mvebu-ahci/description
+ AHCI support for Marvell EBU SoCs
+endef
+
+$(eval $(call KernelPackage,ata-mvebu-ahci))
+
+
 define KernelPackage/ata-nvidia-sata
   TITLE:=Nvidia Serial ATA support
   KCONFIG:=CONFIG_SATA_NV
@@ -98,6 +151,22 @@ endef
 $(eval $(call KernelPackage,ata-nvidia-sata))
 
 
+define KernelPackage/ata-oxnas-sata
+  TITLE:=oxnas Serial ATA support
+  KCONFIG:=CONFIG_SATA_OXNAS
+  DEPENDS:=@TARGET_oxnas
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_oxnas.ko
+  AUTOLOAD:=$(call AutoLoad,41,sata_oxnas,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-oxnas-sata/description
+ SATA support for OX934 core found in the OX82x/PLX782x SoCs
+endef
+
+$(eval $(call KernelPackage,ata-oxnas-sata))
+
+
 define KernelPackage/ata-pdc202xx-old
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Older Promise PATA controller support
@@ -111,7 +180,7 @@ endef
 
 define KernelPackage/ata-pdc202xx-old/description
  This option enables support for the Promise 20246, 20262, 20263,
- 20265 and 20267 adapters.
+ 20265 and 20267 adapters
 endef
 
 $(eval $(call KernelPackage,ata-pdc202xx-old))
@@ -127,7 +196,7 @@ endef
 
 define KernelPackage/ata-piix/description
  SATA support for Intel ICH5/6/7/8 series host controllers and
- PATA support for Intel ESB/ICH/PIIX3/PIIX4 series host controllers.
+ PATA support for Intel ESB/ICH/PIIX3/PIIX4 series host controllers
 endef
 
 $(eval $(call KernelPackage,ata-piix))
@@ -142,7 +211,7 @@ define KernelPackage/ata-sil
 endef
 
 define KernelPackage/ata-sil/description
- Support for Silicon Image Serial ATA controllers.
+ Support for Silicon Image Serial ATA controllers
 endef
 
 $(eval $(call KernelPackage,ata-sil))
@@ -157,7 +226,7 @@ define KernelPackage/ata-sil24
 endef
 
 define KernelPackage/ata-sil24/description
- Support for Silicon Image 3124/3132 Serial ATA controllers.
+ Support for Silicon Image 3124/3132 Serial ATA controllers
 endef
 
 $(eval $(call KernelPackage,ata-sil24))
@@ -172,7 +241,7 @@ define KernelPackage/ata-via-sata
 endef
 
 define KernelPackage/ata-via-sata/description
- This option enables support for VIA Serial ATA.
+ This option enables support for VIA Serial ATA
 endef
 
 $(eval $(call KernelPackage,ata-via-sata))
@@ -200,6 +269,8 @@ define KernelPackage/dm
        CONFIG_DM_DEBUG=n \
        CONFIG_DM_UEVENT=n \
        CONFIG_DM_DELAY=n \
+       CONFIG_DM_LOG_WRITES=n \
+       CONFIG_DM_MQ_DEFAULT=n \
        CONFIG_DM_MULTIPATH=n \
        CONFIG_DM_ZERO=n \
        CONFIG_DM_SNAPSHOT=n \
@@ -306,10 +377,9 @@ $(eval $(call KernelPackage,md-raid10))
 
 
 define KernelPackage/md-raid456
-$(call KernelPackage/md/Depends,+kmod-lib-raid6)
+$(call KernelPackage/md/Depends,+kmod-lib-raid6 +kmod-lib-xor +LINUX_4_4:kmod-lib-crc32c)
   TITLE:=RAID Level 456 Driver
   KCONFIG:= \
-       CONFIG_XOR_BLOCKS \
        CONFIG_ASYNC_CORE \
        CONFIG_ASYNC_MEMCPY \
        CONFIG_ASYNC_XOR \
@@ -319,14 +389,13 @@ $(call KernelPackage/md/Depends,+kmod-lib-raid6)
        CONFIG_MD_RAID456 \
        CONFIG_MULTICORE_RAID456=n
   FILES:= \
-       $(LINUX_DIR)/crypto/xor.ko \
        $(LINUX_DIR)/crypto/async_tx/async_tx.ko \
        $(LINUX_DIR)/crypto/async_tx/async_memcpy.ko \
        $(LINUX_DIR)/crypto/async_tx/async_xor.ko \
        $(LINUX_DIR)/crypto/async_tx/async_pq.ko \
        $(LINUX_DIR)/crypto/async_tx/async_raid6_recov.ko \
-       $(LINUX_DIR)/drivers/md/raid456.ko \
-  AUTOLOAD:=$(call AutoLoad,28, xor async_tx async_memcpy async_xor async_pq async_raid6_recov raid456)
+       $(LINUX_DIR)/drivers/md/raid456.ko
+  AUTOLOAD:=$(call AutoLoad,28, async_tx async_memcpy async_xor async_pq async_raid6_recov raid456)
 endef
 
 define KernelPackage/md-raid456/description
@@ -378,9 +447,6 @@ define KernelPackage/ide-core
   FILES:= \
        $(LINUX_DIR)/drivers/ide/ide-core.ko \
        $(LINUX_DIR)/drivers/ide/ide-gd_mod.ko
-  AUTOLOAD:= \
-       $(call AutoLoad,20,ide-core,1) \
-       $(call AutoLoad,40,ide-gd_mod,1)
 endef
 
 define KernelPackage/ide-core/description
@@ -434,7 +500,7 @@ define KernelPackage/ide-aec62xx
 endef
 
 define KernelPackage/ide-aec62xx/description
- Support for Acard AEC62xx (Artop ATP8xx) IDE controllers.
+ Support for Acard AEC62xx (Artop ATP8xx) IDE controllers
 endef
 
 $(eval $(call KernelPackage,ide-aec62xx,1))
@@ -467,7 +533,7 @@ define KernelPackage/ide-it821x
 endef
 
 define KernelPackage/ide-it821x/description
-  Kernel module for the ITE IDE821x IDE controllers.
+ Kernel module for the ITE IDE821x IDE controllers
 endef
 
 $(eval $(call KernelPackage,ide-it821x))
@@ -489,7 +555,7 @@ define KernelPackage/libsas
 endef
 
 define KernelPackage/libsas/description
-  SAS Domain Transport Attributes support.
+ SAS Domain Transport Attributes support
 endef
 
 $(eval $(call KernelPackage,libsas,1))
@@ -524,7 +590,7 @@ define KernelPackage/mvsas
 endef
 
 define KernelPackage/mvsas/description
 Kernel support for the Marvell SAS SCSI adapters
+ Kernel support for the Marvell SAS SCSI adapters
 endef
 
 $(eval $(call KernelPackage,mvsas))
@@ -552,9 +618,9 @@ define KernelPackage/scsi-core
        CONFIG_SCSI \
        CONFIG_BLK_DEV_SD
   FILES:= \
-       $(if $(findstring y,$(CONFIG_SCSI)),,$(LINUX_DIR)/drivers/scsi/scsi_mod.ko) \
+       $(LINUX_DIR)/drivers/scsi/scsi_mod.ko \
        $(LINUX_DIR)/drivers/scsi/sd_mod.ko
-  AUTOLOAD:=$(call AutoLoad,20,scsi_mod,1) $(call AutoLoad,40,sd_mod,1)
+  AUTOLOAD:=$(call AutoLoad,40,scsi_mod sd_mod,1)
 endef
 
 $(eval $(call KernelPackage,scsi-core))
@@ -584,8 +650,21 @@ define KernelPackage/scsi-cdrom
   FILES:= \
     $(LINUX_DIR)/drivers/cdrom/cdrom.ko \
     $(LINUX_DIR)/drivers/scsi/sr_mod.ko
-  AUTOLOAD:=$(call AutoLoad,30,cdrom) $(call AutoLoad,45,sr_mod)
+  AUTOLOAD:=$(call AutoLoad,45,sr_mod)
 endef
 
 $(eval $(call KernelPackage,scsi-cdrom))
 
+
+define KernelPackage/scsi-tape
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Kernel support for scsi tape drives
+  DEPENDS:=+kmod-scsi-core
+  KCONFIG:= \
+    CONFIG_CHR_DEV_ST
+  FILES:= \
+    $(LINUX_DIR)/drivers/scsi/st.ko
+  AUTOLOAD:=$(call AutoLoad,45,st)
+endef
+
+$(eval $(call KernelPackage,scsi-tape))