kernel: 5.15: add new module
[openwrt/staging/mkresin.git] / package / kernel / linux / modules / block.mk
index e5822d95d78bcb4606a1dcef200a84c3bb4fffc2..dfb529db3bc6bb44c6b65893d81731a25dc6ed5a 100644 (file)
@@ -513,11 +513,13 @@ define KernelPackage/scsi-core
   TITLE:=SCSI device support
   KCONFIG:= \
        CONFIG_SCSI \
+       CONFIG_SCSI_COMMON@ge5.15 \
        CONFIG_BLK_DEV_SD
   FILES:= \
        $(LINUX_DIR)/drivers/scsi/scsi_mod.ko \
+       $(LINUX_DIR)/drivers/scsi/scsi_common.ko@ge5.15 \
        $(LINUX_DIR)/drivers/scsi/sd_mod.ko
-  AUTOLOAD:=$(call AutoLoad,40,scsi_mod sd_mod,1)
+  AUTOLOAD:=$(call AutoLoad,40,scsi_mod scsi_common@ge5.15 sd_mod,1)
 endef
 
 $(eval $(call KernelPackage,scsi-core))