kernel: add missing dependency for kmod-crypto-ghash
[openwrt/staging/jogo.git] / package / kernel / linux / modules / crypto.mk
index 73f36beaa124a3ec9a4d01748f7b60ccad5a5fe2..bcd45061c592935eedcd66e83c16d617f59c4112 100644 (file)
@@ -425,7 +425,7 @@ $(eval $(call KernelPackage,crypto-gf128))
 
 define KernelPackage/crypto-ghash
   TITLE:=GHASH digest CryptoAPI module
-  DEPENDS:=+kmod-crypto-gf128
+  DEPENDS:=+kmod-crypto-gf128 +kmod-crypto-hash
   KCONFIG:=CONFIG_CRYPTO_GHASH
   FILES:=$(LINUX_DIR)/crypto/ghash-generic.ko
   AUTOLOAD:=$(call AutoLoad,09,ghash-generic)