kernel: remove obsolete kernel version dependencies
[openwrt/openwrt.git] / package / kernel / linux / modules / lib.mk
index af536270f60380db3b75302107ebf39baa412c52..7c17a0a1f6ffe7c7845e39b4a7a7671c36039ee4 100644 (file)
@@ -117,6 +117,26 @@ endef
 $(eval $(call KernelPackage,lib-lzo))
 
 
+define KernelPackage/lib-lz4
+  SUBMENU:=$(LIB_MENU)
+  DEPENDS:=@!LINUX_3_10 @!LINUX_3_14
+  TITLE:=LZ4 support
+  KCONFIG:= \
+       CONFIG_LZ4_COMPRESS \
+       CONFIG_LZ4_DECOMPRESS
+  FILES:= \
+       $(LINUX_DIR)/lib/lz4/lz4_compress.ko \
+       $(LINUX_DIR)/lib/lz4/lz4_decompress.ko
+  AUTOLOAD:=$(call AutoProbe,lz4_compress lz4_decompress)
+endef
+
+define KernelPackage/lib-lz4/description
+ Kernel module for LZ4 compression/decompression support
+endef
+
+$(eval $(call KernelPackage,lib-lz4))
+
+
 define KernelPackage/lib-raid6
   SUBMENU:=$(LIB_MENU)
   TITLE:=RAID6 algorithm support
@@ -138,8 +158,15 @@ define KernelPackage/lib-xor
   TITLE:=XOR blocks algorithm support
   HIDDEN:=1
   KCONFIG:=CONFIG_XOR_BLOCKS
+ifneq ($(wildcard $(LINUX_DIR)/arch/arm/lib/xor-neon.ko),)
+  FILES:= \
+    $(LINUX_DIR)/crypto/xor.ko \
+    $(LINUX_DIR)/arch/arm/lib/xor-neon.ko
+  AUTOLOAD:=$(call AutoProbe,xor-neon xor)
+else
   FILES:=$(LINUX_DIR)/crypto/xor.ko
   AUTOLOAD:=$(call AutoProbe,xor)
+endif
 endef
 
 define KernelPackage/lib-xor/description