move the deflate crypto module out of the crypto core and into a separate package...
[openwrt/openwrt.git] / package / kernel / modules / crypto.mk
index 5cf3b0d3b6b7b252a5e765c8b319d2e14ca8ee39..4600c67b3356825d3baa0a5bf449a47ec62c76c4 100644 (file)
@@ -29,8 +29,7 @@ CRYPTO_MODULES = \
        HASH2=crypto_hash \
        MANAGER2=cryptomgr \
        CBC=cbc \
-       ECB=ecb \
-       DEFLATE=deflate
+       ECB=ecb
 
 crypto_confvar=CONFIG_CRYPTO_$(word 1,$(subst =,$(space),$(1)))
 crypto_file=$(if $(findstring y,$($(call crypto_confvar,$(1)))),,$(LINUX_DIR)/crypto/$(word 2,$(subst =,$(space),$(1))).ko)
@@ -183,6 +182,16 @@ endef
 
 $(eval $(call KernelPackage,crypto-des))
 
+define KernelPackage/crypto-deflate
+  TITLE:=Deflate compression CryptoAPI module
+  KCONFIG:=CONFIG_CRYPTO_DEFLATE
+  FILES:=$(LINUX_DIR)/crypto/deflate.ko
+  AUTOLOAD:=$(call AutoLoad,09,deflate)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-deflate))
+
 
 define KernelPackage/crypto-hmac
   TITLE:=HMAC digest CryptoAPI module