kernel: disable scheduler actions by default, they will be enabled only when kmod...
[openwrt/openwrt.git] / package / kernel / modules / hwmon.mk
index bd008fd0946171664412ab69e1684cf7aad35726..ebbe7cfabcabf6e98594351240338e5471c7c591 100644 (file)
@@ -10,12 +10,11 @@ HWMON_MENU:=Hardware Monitoring Support
 define KernelPackage/hwmon-core
   SUBMENU:=$(HWMON_MENU)
   TITLE:=Hardware monitoring support
-  DEPENDS:=@LINUX_2_6
   KCONFIG:= \
        CONFIG_HWMON \
        CONFIG_HWMON_DEBUG_CHIP=n
   FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon.$(LINUX_KMOD_SUFFIX)
+       $(LINUX_DIR)/drivers/hwmon/hwmon.ko
   AUTOLOAD:=$(call AutoLoad,40,hwmon)
 endef
 
@@ -31,13 +30,27 @@ define AddDepends/hwmon
   DEPENDS:=kmod-hwmon-core $(1)
 endef
 
+define KernelPackage/hwmon-lm63
+  TITLE:=LM63/64 monitoring support
+  KCONFIG:=CONFIG_SENSORS_LM63
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm63.ko
+  AUTOLOAD:=$(call AutoLoad,60,lm63)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-lm63/description
+ Kernel module for lm63 and lm64 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm63))
+
 
 define KernelPackage/hwmon-lm75
-$(call AddDepends/hwmon,+kmod-i2c-core)
   TITLE:=LM75 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM75
-  FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.ko
   AUTOLOAD:=$(call AutoLoad,60,lm75)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
 define KernelPackage/hwmon-lm75/description
@@ -48,11 +61,11 @@ $(eval $(call KernelPackage,hwmon-lm75))
 
 
 define KernelPackage/hwmon-lm77
-$(call AddDepends/hwmon,+kmod-i2c-core)
   TITLE:=LM77 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM77
-  FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.ko
   AUTOLOAD:=$(call AutoLoad,60,lm77)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
 define KernelPackage/hwmon-lm77/description
@@ -61,12 +74,13 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm77))
 
+
 define KernelPackage/hwmon-lm90
-$(call AddDepends/hwmon,+kmod-i2c-core)
   TITLE:=LM90 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM90
-  FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.ko
   AUTOLOAD:=$(call AutoLoad,60,lm90)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
 define KernelPackage/hwmon-lm90/description
@@ -75,16 +89,17 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm90))
 
+
 define KernelPackage/hwmon-pc87360
-$(call AddDepends/hwmon,@TARGET_x86)
   TITLE:=PC87360 monitoring support
   KCONFIG:= \
        CONFIG_SENSORS_PC87360 \
        CONFIG_HWMON_VID
   FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
+       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.ko \
+       $(LINUX_DIR)/drivers/hwmon/pc87360.ko
   AUTOLOAD:=$(call AutoLoad,50,hwmon-vid pc87360)
+  $(call AddDepends/hwmon,@TARGET_x86)
 endef
 
 define KernelPackage/hwmon-pc87360/description
@@ -93,16 +108,17 @@ endef
 
 $(eval $(call KernelPackage,hwmon-pc87360))
 
+
 define KernelPackage/hwmon-w83627hf
-$(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86)
   TITLE:=Winbond W83627HF monitoring support
   KCONFIG:= \
        CONFIG_SENSORS_W83627HF \
        CONFIG_HWMON_VID
   FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/hwmon/w83627hf.$(LINUX_KMOD_SUFFIX)
+       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.ko \
+       $(LINUX_DIR)/drivers/hwmon/w83627hf.ko
   AUTOLOAD:=$(call AutoLoad,50,hwmon-vid w83627hf)
+$(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86)
 endef
 
 define KernelPacakge/hwmon-w83627hf/description