mbedtls: tune config to reduce size and improve performance
[openwrt/openwrt.git] / package / libs / elfutils / patches / 006-libdw_LIBS.patch
index 5e4e28d56b7b3035e4c2d45c26041ce9749f6293..80c20ad5f0d284ae17defd78ccb1991bc047d8ad 100644 (file)
@@ -1,11 +1,11 @@
 --- a/libdw/Makefile.in
 +++ b/libdw/Makefile.in
-@@ -980,7 +980,7 @@ libdw.so$(EXEEXT): $(srcdir)/libdw.map l
+@@ -1002,7 +1002,7 @@ libdw.so$(EXEEXT): $(srcdir)/libdw.map l
                -Wl,--enable-new-dtags,-rpath,$(pkglibdir) \
                -Wl,--version-script,$<,--no-undefined \
                -Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
--              -ldl $(argp_LDADD) $(zip_LIBS)
-+              -ldl $(argp_LDADD) $(zip_LIBS) $(LIBS)
+-              -ldl -lz $(argp_LDADD) $(zip_LIBS)
++              -ldl -lz $(argp_LDADD) $(zip_LIBS) $(LIBS)
        @$(textrel_check)
-       ln -fs $@ $@.$(VERSION)
+       $(AM_V_at)ln -fs $@ $@.$(VERSION)