nghttp2: deduplicate files in staging_dir
[openwrt/openwrt.git] / package / libs / libjson-c / Makefile
index fd785cdb5ea1397988ac04cb39976a1204d5ae98..23cc7b5de4595fba65c09143bd5ef47c2bdaef04 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=json-c
 PKG_VERSION:=0.12.1
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nodoc.tar.gz
 PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
@@ -31,12 +31,14 @@ include $(INCLUDE_DIR)/host-build.mk
 
 TARGET_CFLAGS += $(FPIC) -Wno-implicit-fallthrough
 HOST_CFLAGS += -Wno-implicit-fallthrough
+HOST_BUILD_PREFIX:=$(STAGING_DIR_HOST)
 
 define Package/libjson-c
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=javascript object notation
   URL:=https://json-c.github.io/json-c/
+  ABI_VERSION:=2
 endef
 
 define Package/libjson-c/description