ath9k: add a locking fix that might prevent random memory corruption during hardware...
[openwrt/openwrt.git] / package / mac80211 / patches / 007-remove_misc_drivers.patch
index 89757b0644bd928ccab6cff5243f1f2c769ad424..39bef1868ad80dd87697d3f31c1fa4dc210baaee 100644 (file)
@@ -1,15 +1,15 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -196,7 +196,7 @@ ifneq ($(CONFIG_WIRELESS_EXT),)
- endif
+@@ -196,7 +196,7 @@ $(warning "WARNING: CONFIG_CFG80211_WEXT
+ endif #CONFIG_WIRELESS_EXT
  
  ifneq ($(CONFIG_STAGING),)
--CONFIG_COMPAT_STAGING=m
+- CONFIG_COMPAT_STAGING=m
 +# CONFIG_COMPAT_STAGING=m
  endif
  
  # mac80211 test driver
-@@ -306,13 +306,13 @@ endif
+@@ -314,13 +314,13 @@ endif #CONFIG_CRC_ITU_T
  CONFIG_MWL8K=m
  
  # Ethernet drivers go here
@@ -27,8 +27,8 @@
 +# CONFIG_ATL1C=m
  endif #CONFIG_COMPAT_KERNEL_27
  
- CONFIG_HERMES=m
-@@ -361,17 +361,17 @@ CONFIG_ZD1211RW=m
+ ifdef CONFIG_WIRELESS_EXT
+@@ -371,17 +371,17 @@ CONFIG_ZD1211RW=m
  # Note: this depends on CONFIG_USB_NET_RNDIS_HOST and CONFIG_USB_NET_CDCETHER
  # it also requires new RNDIS_HOST and CDC_ETHER modules which we add
  ifdef CONFIG_COMPAT_KERNEL_29
  endif #CONFIG_COMPAT_KERNEL_29
  
  
-@@ -474,17 +474,17 @@ CONFIG_BT_MRVL_SDIO=m
- ifneq ($(CONFIG_COMPAT_STAGING),)
- ifdef CONFIG_COMPAT_KERNEL_32
--CONFIG_ATH6KL_CFG80211=y
--CONFIG_ATH6KL_DEBUG=y
-+# CONFIG_ATH6KL_CFG80211=y
-+# CONFIG_ATH6KL_DEBUG=y
- # CONFIG_ATH6KL_DISABLE_TARGET_DBGLOGS is not set
- # CONFIG_ATH6KL_ENABLE_COEXISTENCE is not set
- # CONFIG_ATH6KL_ENABLE_HOST_DEBUG is not set
--CONFIG_ATH6KL_ENABLE_TARGET_DEBUG_PRINTS=y
-+# CONFIG_ATH6KL_ENABLE_TARGET_DEBUG_PRINTS=y
- # CONFIG_ATH6KL_HCI_BRIDGE is not set
- # CONFIG_ATH6KL_HTC_RAW_INTERFACE is not set
- # CONFIG_ATH6KL_SKIP_ABI_VERSION_CHECK is not set
--CONFIG_ATH6KL_VIRTUAL_SCATTER_GATHER=y
--CONFIG_ATH6K_LEGACY=m
-+# CONFIG_ATH6KL_VIRTUAL_SCATTER_GATHER=y
-+# CONFIG_ATH6K_LEGACY=m
- endif #CONFIG_COMPAT_KERNEL_32
- endif