firewall: bump to git HEAD
[openwrt/openwrt.git] / package / network / config / firewall / Makefile
index 44da26d4952c5f93739977ee1a452a6b93db1df9..830a1b268f15e9e6f8251791cf7bdf7e886c34f6 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/firewall3.git
-PKG_SOURCE_DATE:=2018-03-20
-PKG_SOURCE_VERSION:=5cdf15eead8153f81c3f80c4f58164f950845ac1
-PKG_MIRROR_HASH:=eaec17deb0f6712b73744d90b5af397ae418712b69be6fcbaebbe4c6cc9652fc
+PKG_SOURCE_DATE:=2018-08-13
+PKG_SOURCE_VERSION:=1c4d5bcd1137e61e91dca858fe33d76d7a1dc821
+PKG_MIRROR_HASH:=49f939877a734056455556c90b959c407fd2c4988dc5d86f62a8122ebd7b8899
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC
 
@@ -40,8 +40,8 @@ define Package/firewall/conffiles
 /etc/firewall.user
 endef
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
+TARGET_LDFLAGS += -Wl,--gc-sections -flto
 CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DDISABLE_IPV6=1)
 
 define Package/firewall/install