gre: Support fqdn as remote tunnel endpoint
[openwrt/staging/mkresin.git] / package / network / config / gre / Makefile
index 9c5c13f1691f837db2d0ffe6a868fe4b24cff330..2e05ffca6fa8877794415206eab90851145bb664 100644 (file)
@@ -9,7 +9,8 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gre
 PKG_VERSION:=1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
+PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,7 +32,7 @@ endef
 define Package/grev4
 $(call Package/gre/Default)
   TITLE:=Generic Routing Encapsulation (IPv4) config support
-  DEPENDS:=@(PACKAGE_gre) +kmod-gre
+  DEPENDS:=@(PACKAGE_gre) +kmod-gre +resolveip
 endef
 
 define Package/grev4/description
@@ -41,7 +42,7 @@ endef
 define Package/grev6
 $(call Package/gre/Default)
   TITLE:=Generic Routing Encapsulation (IPv6) config support
-  DEPENDS:=@(PACKAGE_gre) +kmod-ipv6 +kmod-ip6-gre
+  DEPENDS:=@(PACKAGE_gre) @IPV6 +kmod-gre6 +resolveip
 endef
 
 define Package/grev6/description