hostapd: Update to version 2.8 (2019-04-21)
[openwrt/openwrt.git] / package / network / services / hostapd / patches / 370-ap_sta_support.patch
index a77d4c92e6d7fa7711338c82aba27b7e44248afe..79dc3f56e87a1b9472139035733e535ee4bfb541 100644 (file)
@@ -1,26 +1,3 @@
---- a/wpa_supplicant/wpa_supplicant_i.h
-+++ b/wpa_supplicant/wpa_supplicant_i.h
-@@ -100,6 +100,11 @@ struct wpa_interface {
-       const char *ifname;
-       /**
-+       * hostapd_ctrl - path to hostapd control socket for notification
-+       */
-+      const char *hostapd_ctrl;
-+
-+      /**
-        * bridge_ifname - Optional bridge interface name
-        *
-        * If the driver interface (ifname) is included in a Linux bridge
-@@ -484,6 +489,8 @@ struct wpa_supplicant {
- #endif /* CONFIG_CTRL_IFACE_BINDER */
-       char bridge_ifname[16];
-+      struct wpa_ctrl *hostapd;
-+
-       char *confname;
-       char *confanother;
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
 @@ -26,6 +26,10 @@ CFLAGS += $(EXTRA_CFLAGS)
@@ -34,8 +11,8 @@
  -include .config
  -include $(if $(MULTICALL),../hostapd/.config)
  
-@@ -113,6 +117,8 @@ OBJS_c += ../src/utils/wpa_debug.o
- OBJS_c += ../src/utils/common.o
+@@ -116,6 +120,8 @@ OBJS_c += ../src/utils/common.o
+ OBJS_c += ../src/common/cli.o
  OBJS += wmm_ac.o
  
 +OBJS += ../src/common/wpa_ctrl.o
  ifndef CONFIG_OS
  ifdef CONFIG_NATIVE_WINDOWS
  CONFIG_OS=win32
+--- a/wpa_supplicant/bss.c
++++ b/wpa_supplicant/bss.c
+@@ -11,6 +11,7 @@
+ #include "utils/common.h"
+ #include "utils/eloop.h"
+ #include "common/ieee802_11_defs.h"
++#include "common/ieee802_11_common.h"
+ #include "drivers/driver.h"
+ #include "eap_peer/eap.h"
+ #include "wpa_supplicant_i.h"
+@@ -294,6 +295,10 @@ void calculate_update_time(const struct
+ static void wpa_bss_copy_res(struct wpa_bss *dst, struct wpa_scan_res *src,
+                            struct os_reltime *fetch_time)
+ {
++      struct ieee80211_ht_capabilities *capab;
++      struct ieee80211_ht_operation *oper;
++      struct ieee802_11_elems elems;
++
+       dst->flags = src->flags;
+       os_memcpy(dst->bssid, src->bssid, ETH_ALEN);
+       dst->freq = src->freq;
+@@ -306,6 +311,15 @@ static void wpa_bss_copy_res(struct wpa_
+       dst->est_throughput = src->est_throughput;
+       dst->snr = src->snr;
++      memset(&elems, 0, sizeof(elems));
++      ieee802_11_parse_elems((u8 *) (src + 1), src->ie_len, &elems, 0);
++      capab = (struct ieee80211_ht_capabilities *) elems.ht_capabilities;
++      oper = (struct ieee80211_ht_operation *) elems.ht_operation;
++      if (capab)
++              dst->ht_capab = le_to_host16(capab->ht_capabilities_info);
++      if (oper)
++              dst->ht_param = oper->ht_param;
++
+       calculate_update_time(fetch_time, src->age, &dst->last_update);
+ }
+--- a/wpa_supplicant/bss.h
++++ b/wpa_supplicant/bss.h
+@@ -82,6 +82,10 @@ struct wpa_bss {
+       u8 ssid[SSID_MAX_LEN];
+       /** Length of SSID */
+       size_t ssid_len;
++      /** HT capabilities */
++      u16 ht_capab;
++      /* Five octets of HT Operation Information */
++      u8 ht_param;
+       /** Frequency of the channel in MHz (e.g., 2412 = channel 1) */
+       int freq;
+       /** Beacon interval in TUs (host byte order) */
+--- a/wpa_supplicant/main.c
++++ b/wpa_supplicant/main.c
+@@ -34,7 +34,7 @@ static void usage(void)
+              "vW] [-P<pid file>] "
+              "[-g<global ctrl>] \\\n"
+              "        [-G<group>] \\\n"
+-             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] "
++             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] [-H<hostapd path>] "
+              "[-p<driver_param>] \\\n"
+              "        [-b<br_ifname>] [-e<entropy file>]"
+ #ifdef CONFIG_DEBUG_FILE
+@@ -74,6 +74,7 @@ static void usage(void)
+              "  -g = global ctrl_interface\n"
+              "  -G = global ctrl_interface group\n"
+              "  -h = show this help text\n"
++             "  -H = connect to a hostapd instance to manage state changes\n"
+              "  -i = interface name\n"
+              "  -I = additional configuration file\n"
+              "  -K = include keys (passwords, etc.) in debug output\n"
+@@ -201,7 +202,7 @@ int main(int argc, char *argv[])
+       for (;;) {
+               c = getopt(argc, argv,
+-                         "b:Bc:C:D:de:f:g:G:hi:I:KLMm:No:O:p:P:qsTtuvW");
++                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLMm:No:O:p:P:qsTtuvW");
+               if (c < 0)
+                       break;
+               switch (c) {
+@@ -248,6 +249,9 @@ int main(int argc, char *argv[])
+                       usage();
+                       exitcode = 0;
+                       goto out;
++              case 'H':
++                      iface->hostapd_ctrl = optarg;
++                      break;
+               case 'i':
+                       iface->ifname = optarg;
+                       break;
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -112,6 +112,55 @@ const char *const wpa_supplicant_full_li
- "\n";
- #endif /* CONFIG_NO_STDOUT_DEBUG */
+@@ -126,6 +126,55 @@ static void wpas_update_fils_connect_par
+ #endif /* CONFIG_FILS && IEEE8021X_EAPOL */
  
 +static int hostapd_stop(struct wpa_supplicant *wpa_s)
 +{
  /* Configure default/group WEP keys for static WEP */
  int wpa_set_wep_keys(struct wpa_supplicant *wpa_s, struct wpa_ssid *ssid)
  {
-@@ -812,8 +861,12 @@ void wpa_supplicant_set_state(struct wpa
-               wpas_p2p_completed(wpa_s);
+@@ -940,12 +989,16 @@ void wpa_supplicant_set_state(struct wpa
  
                sme_sched_obss_scan(wpa_s, 1);
 +              if (wpa_s->hostapd)
 +                      hostapd_reload(wpa_s, wpa_s->current_bss);
+ #if defined(CONFIG_FILS) && defined(IEEE8021X_EAPOL)
+               if (!fils_hlp_sent && ssid && ssid->eap.erp)
+                       wpas_update_fils_connect_params(wpa_s);
+ #endif /* CONFIG_FILS && IEEE8021X_EAPOL */
        } else if (state == WPA_DISCONNECTED || state == WPA_ASSOCIATING ||
                   state == WPA_ASSOCIATED) {
 +              if (wpa_s->hostapd)
                wpa_s->new_connection = 1;
                wpa_drv_set_operstate(wpa_s, 0);
  #ifndef IEEE8021X_EAPOL
-@@ -4646,6 +4699,20 @@ static int wpa_supplicant_init_iface(str
+@@ -2035,6 +2088,8 @@ void wpa_supplicant_associate(struct wpa
+                       wpa_ssid_txt(ssid->ssid, ssid->ssid_len),
+                       ssid->id);
+               wpas_notify_mesh_group_started(wpa_s, ssid);
++              if (wpa_s->hostapd)
++                      hostapd_reload(wpa_s, wpa_s->current_bss);
+ #else /* CONFIG_MESH */
+               wpa_msg(wpa_s, MSG_ERROR,
+                       "mesh mode support not included in the build");
+@@ -5707,6 +5762,16 @@ static int wpa_supplicant_init_iface(str
                           sizeof(wpa_s->bridge_ifname));
        }
  
 +      if (iface->hostapd_ctrl) {
-+              char *cmd = "STOP_AP";
-+              char buf[256];
-+              int len = sizeof(buf);
-+
 +              wpa_s->hostapd = wpa_ctrl_open(iface->hostapd_ctrl);
 +              if (!wpa_s->hostapd) {
 +                      wpa_printf(MSG_ERROR, "\nFailed to connect to hostapd\n");
        /* RSNA Supplicant Key Management - INITIALIZE */
        eapol_sm_notify_portEnabled(wpa_s->eapol, FALSE);
        eapol_sm_notify_portValid(wpa_s->eapol, FALSE);
-@@ -4937,6 +5004,11 @@ static void wpa_supplicant_deinit_iface(
+@@ -6034,6 +6099,11 @@ static void wpa_supplicant_deinit_iface(
        if (terminate)
                wpa_msg(wpa_s, MSG_INFO, WPA_EVENT_TERMINATING);
  
        if (wpa_s->ctrl_iface) {
                wpa_supplicant_ctrl_iface_deinit(wpa_s->ctrl_iface);
                wpa_s->ctrl_iface = NULL;
---- a/wpa_supplicant/bss.c
-+++ b/wpa_supplicant/bss.c
-@@ -11,6 +11,7 @@
- #include "utils/common.h"
- #include "utils/eloop.h"
- #include "common/ieee802_11_defs.h"
-+#include "common/ieee802_11_common.h"
- #include "drivers/driver.h"
- #include "wpa_supplicant_i.h"
- #include "config.h"
-@@ -287,6 +288,10 @@ static void calculate_update_time(const
- static void wpa_bss_copy_res(struct wpa_bss *dst, struct wpa_scan_res *src,
-                            struct os_reltime *fetch_time)
- {
-+      struct ieee80211_ht_capabilities *capab;
-+      struct ieee80211_ht_operation *oper;
-+      struct ieee802_11_elems elems;
+--- a/wpa_supplicant/wpa_supplicant_i.h
++++ b/wpa_supplicant/wpa_supplicant_i.h
+@@ -101,6 +101,11 @@ struct wpa_interface {
+       const char *ifname;
+       /**
++       * hostapd_ctrl - path to hostapd control socket for notification
++       */
++      const char *hostapd_ctrl;
 +
-       dst->flags = src->flags;
-       os_memcpy(dst->bssid, src->bssid, ETH_ALEN);
-       dst->freq = src->freq;
-@@ -299,6 +304,15 @@ static void wpa_bss_copy_res(struct wpa_
-       dst->est_throughput = src->est_throughput;
-       dst->snr = src->snr;
++      /**
+        * bridge_ifname - Optional bridge interface name
+        *
+        * If the driver interface (ifname) is included in a Linux bridge
+@@ -516,6 +521,8 @@ struct wpa_supplicant {
+ #endif /* CONFIG_CTRL_IFACE_BINDER */
+       char bridge_ifname[16];
  
-+      memset(&elems, 0, sizeof(elems));
-+      ieee802_11_parse_elems((u8 *) (src + 1), src->ie_len, &elems, 0);
-+      capab = (struct ieee80211_ht_capabilities *) elems.ht_capabilities;
-+      oper = (struct ieee80211_ht_operation *) elems.ht_operation;
-+      if (capab)
-+              dst->ht_capab = le_to_host16(capab->ht_capabilities_info);
-+      if (oper)
-+              dst->ht_param = oper->ht_param;
++      struct wpa_ctrl *hostapd;
 +
-       calculate_update_time(fetch_time, src->age, &dst->last_update);
+       char *confname;
+       char *confanother;
+--- a/hostapd/ctrl_iface.c
++++ b/hostapd/ctrl_iface.c
+@@ -2385,6 +2385,11 @@ static int hostapd_ctrl_iface_chan_switc
+       if (ret)
+               return ret;
++      if (os_strstr(pos, " auto-ht")) {
++              settings.freq_params.ht_enabled = iface->conf->ieee80211n;
++              settings.freq_params.vht_enabled = iface->conf->ieee80211ac;
++      }
++
+       for (i = 0; i < iface->num_bss; i++) {
+               /* Save CHAN_SWITCH VHT config */
+--- a/src/ap/beacon.c
++++ b/src/ap/beacon.c
+@@ -1397,11 +1397,6 @@ int ieee802_11_set_beacon(struct hostapd
+       struct wpabuf *beacon, *proberesp, *assocresp;
+       int res, ret = -1;
+-      if (hapd->csa_in_progress) {
+-              wpa_printf(MSG_ERROR, "Cannot set beacons during CSA period");
+-              return -1;
+-      }
+-
+       hapd->beacon_set_done = 1;
+       if (ieee802_11_build_ap_params(hapd, &params) < 0)
+--- a/src/drivers/driver.h
++++ b/src/drivers/driver.h
+@@ -4544,6 +4544,13 @@ enum wpa_event_type {
+       EVENT_CH_SWITCH,
+       /**
++       * EVENT_CH_SWITCH - AP or GO will switch channels soon
++       *
++       * Described in wpa_event_data.ch_switch
++       * */
++      EVENT_CH_SWITCH_STARTED,
++
++      /**
+        * EVENT_WNM - Request WNM operation
+        *
+        * This event can be used to request a WNM operation to be performed.
+@@ -5381,6 +5388,7 @@ union wpa_event_data {
+       /**
+        * struct ch_switch
++       * @count: countdown until channel switch
+        * @freq: Frequency of new channel in MHz
+        * @ht_enabled: Whether this is an HT channel
+        * @ch_offset: Secondary channel offset
+@@ -5389,6 +5397,7 @@ union wpa_event_data {
+        * @cf2: Center frequency 2
+        */
+       struct ch_switch {
++              int count;
+               int freq;
+               int ht_enabled;
+               int ch_offset;
+--- a/src/drivers/driver_nl80211_event.c
++++ b/src/drivers/driver_nl80211_event.c
+@@ -534,7 +534,8 @@ static int calculate_chan_offset(int wid
+ static void mlme_event_ch_switch(struct wpa_driver_nl80211_data *drv,
+                                struct nlattr *ifindex, struct nlattr *freq,
+                                struct nlattr *type, struct nlattr *bw,
+-                               struct nlattr *cf1, struct nlattr *cf2)
++                               struct nlattr *cf1, struct nlattr *cf2,
++                               struct nlattr *count)
+ {
+       struct i802_bss *bss;
+       union wpa_event_data data;
+@@ -592,11 +593,15 @@ static void mlme_event_ch_switch(struct
+               data.ch_switch.cf1 = nla_get_u32(cf1);
+       if (cf2)
+               data.ch_switch.cf2 = nla_get_u32(cf2);
++      if (count)
++              data.ch_switch.count = nla_get_u32(count);
+       bss->freq = data.ch_switch.freq;
+       drv->assoc_freq = data.ch_switch.freq;
+-      wpa_supplicant_event(bss->ctx, EVENT_CH_SWITCH, &data);
++      wpa_supplicant_event(bss->ctx,
++                           count ? EVENT_CH_SWITCH_STARTED : EVENT_CH_SWITCH,
++                           &data);
  }
  
---- a/wpa_supplicant/main.c
-+++ b/wpa_supplicant/main.c
-@@ -34,7 +34,7 @@ static void usage(void)
-              "vW] [-P<pid file>] "
-              "[-g<global ctrl>] \\\n"
-              "        [-G<group>] \\\n"
--             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] "
-+             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] [-H<hostapd path>] "
-              "[-p<driver_param>] \\\n"
-              "        [-b<br_ifname>] [-e<entropy file>]"
- #ifdef CONFIG_DEBUG_FILE
-@@ -74,6 +74,7 @@ static void usage(void)
-              "  -g = global ctrl_interface\n"
-              "  -G = global ctrl_interface group\n"
-              "  -h = show this help text\n"
-+             "  -H = connect to a hostapd instance to manage state changes\n"
-              "  -i = interface name\n"
-              "  -I = additional configuration file\n"
-              "  -K = include keys (passwords, etc.) in debug output\n"
-@@ -201,7 +202,7 @@ int main(int argc, char *argv[])
  
-       for (;;) {
-               c = getopt(argc, argv,
--                         "b:Bc:C:D:de:f:g:G:hi:I:KLMm:No:O:p:P:qsTtuvW");
-+                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLMm:No:O:p:P:qsTtuvW");
-               if (c < 0)
-                       break;
-               switch (c) {
-@@ -248,6 +249,9 @@ int main(int argc, char *argv[])
-                       usage();
-                       exitcode = 0;
-                       goto out;
-+              case 'H':
-+                      iface->hostapd_ctrl = optarg;
-+                      break;
-               case 'i':
-                       iface->ifname = optarg;
+@@ -2508,6 +2513,7 @@ static void do_process_drv_event(struct
+                                  tb[NL80211_ATTR_PMK],
+                                  tb[NL80211_ATTR_PMKID]);
+               break;
++      case NL80211_CMD_CH_SWITCH_STARTED_NOTIFY:
+       case NL80211_CMD_CH_SWITCH_NOTIFY:
+               mlme_event_ch_switch(drv,
+                                    tb[NL80211_ATTR_IFINDEX],
+@@ -2515,7 +2521,8 @@ static void do_process_drv_event(struct
+                                    tb[NL80211_ATTR_WIPHY_CHANNEL_TYPE],
+                                    tb[NL80211_ATTR_CHANNEL_WIDTH],
+                                    tb[NL80211_ATTR_CENTER_FREQ1],
+-                                   tb[NL80211_ATTR_CENTER_FREQ2]);
++                                   tb[NL80211_ATTR_CENTER_FREQ2],
++                                   tb[NL80211_ATTR_CH_SWITCH_COUNT]);
+               break;
+       case NL80211_CMD_DISCONNECT:
+               mlme_event_disconnect(drv, tb[NL80211_ATTR_REASON_CODE],
+--- a/wpa_supplicant/events.c
++++ b/wpa_supplicant/events.c
+@@ -4176,6 +4176,60 @@ static void wpas_event_assoc_reject(stru
+ }
++static void
++supplicant_ch_switch_started(struct wpa_supplicant *wpa_s,
++                          union wpa_event_data *data)
++{
++      char buf[256];
++      size_t len = sizeof(buf);
++      char *cmd = NULL;
++      int width = 20;
++      int ret;
++
++      if (!wpa_s->hostapd)
++              return;
++
++      wpa_msg(wpa_s, MSG_INFO, WPA_EVENT_CHANNEL_SWITCH
++              "count=%d freq=%d ht_enabled=%d ch_offset=%d ch_width=%s cf1=%d cf2=%d",
++              data->ch_switch.count,
++              data->ch_switch.freq,
++              data->ch_switch.ht_enabled,
++              data->ch_switch.ch_offset,
++              channel_width_to_string(data->ch_switch.ch_width),
++              data->ch_switch.cf1,
++              data->ch_switch.cf2);
++
++      switch (data->ch_switch.ch_width) {
++      case CHAN_WIDTH_20_NOHT:
++      case CHAN_WIDTH_20:
++              width = 20;
++              break;
++      case CHAN_WIDTH_40:
++              width = 40;
++              break;
++      case CHAN_WIDTH_80:
++              width = 80;
++              break;
++      case CHAN_WIDTH_160:
++      case CHAN_WIDTH_80P80:
++              width = 160;
++              break;
++      }
++
++      asprintf(&cmd, "CHAN_SWITCH %d %d sec_channel_offset=%d center_freq1=%d center_freq2=%d, bandwidth=%d auto-ht\n",
++              data->ch_switch.count - 1,
++              data->ch_switch.freq,
++              data->ch_switch.ch_offset,
++              data->ch_switch.cf1,
++              data->ch_switch.cf2,
++              width);
++      ret = wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL);
++      free(cmd);
++
++      if (ret < 0)
++              wpa_printf(MSG_ERROR, "\nFailed to reload hostapd AP interfaces\n");
++}
++
+ void supplicant_event(void *ctx, enum wpa_event_type event,
+                     union wpa_event_data *data)
+ {
+@@ -4461,6 +4515,10 @@ void supplicant_event(void *ctx, enum wp
+                                      data->rx_from_unknown.wds);
+               break;
+ #endif /* CONFIG_AP */
++      case EVENT_CH_SWITCH_STARTED:
++              supplicant_ch_switch_started(wpa_s, data);
++              break;
++
+       case EVENT_CH_SWITCH:
+               if (!data || !wpa_s->current_ssid)
                        break;
---- a/wpa_supplicant/bss.h
-+++ b/wpa_supplicant/bss.h
-@@ -79,6 +79,10 @@ struct wpa_bss {
-       u8 ssid[SSID_MAX_LEN];
-       /** Length of SSID */
-       size_t ssid_len;
-+      /** HT capabilities */
-+      u16 ht_capab;
-+      /* Five octets of HT Operation Information */
-+      u8 ht_param;
-       /** Frequency of the channel in MHz (e.g., 2412 = channel 1) */
-       int freq;
-       /** Beacon interval in TUs (host byte order) */