[package] ppp: enable multilink support (#4837)
[openwrt/svn-archive/archive.git] / package / opkg / Makefile
index 9b67e3982c5484677ce64f4bfffd799e4ca5bd15..6894ae7cb445a71d87faa9aceca93f02789c2d91 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=opkg
-PKG_REV:=215
+PKG_REV:=513
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=3
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
@@ -47,7 +47,8 @@ EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 CONFIGURE_ARGS += \
        --disable-curl \
        --disable-gpg \
-       --with-ipkgetcdir=/etc
+       --with-opkgetcdir=/etc \
+       --with-opkglockfile=/var/lock/opkg.lock
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \