procd: depend on libubox directly to rebuild on ABI changes
[openwrt/openwrt.git] / package / system / procd / Makefile
index 6cce8045d0d01612ffec2152b536a426e4d3dc96..86b64067ab0e6eda5c2b067dafd7b50e9097a4ac 100644 (file)
@@ -1,14 +1,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2013-11-15
+PKG_VERSION:=2014-02-17
 
-PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=93d71ca996eb50b951169414cf541bf0fe4f647e
+PKG_SOURCE_VERSION:=3a225cfa1782763980c86e9811c683ade33012cc
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -25,7 +25,7 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
 define Package/procd
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt
+  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox
   TITLE:=OpenWrt system process manager
 endef