treewide: replace AUTORELEASE with real PKG_RELEASE
[openwrt/openwrt.git] / package / system / zram-swap / Makefile
index 2bb0d7c263597b1a480838f062f6b3fd0bb54643..6e7e353f6fd768578036b8386dc8091d6ddbc7fd 100644 (file)
@@ -1,34 +1,33 @@
-# 
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# SPDX-License-Identifier: GPL-2.0-only
 #
+# Copyright (C) 2013-2021 OpenWrt.org
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zram-swap
-PKG_VERSION:=1
-PKG_RELEASE:=2
+PKG_RELEASE:=32
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-PKG_LICENSE:=GPL-2.0
-PKG_LICENSE_FILES:=
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/zram-swap
   SECTION:=utils
   CATEGORY:=Base system
-  DEPENDS:=+kmod-zram +!BUSYBOX_CONFIG_MKSWAP:swap-utils +!BUSYBOX_CONFIG_SWAPONOFF:block-mount
+  DEPENDS:= \
+       +@BUSYBOX_CONFIG_FEATURE_SWAPON_DISCARD \
+       +@BUSYBOX_CONFIG_FEATURE_SWAPON_PRI \
+       +@BUSYBOX_CONFIG_MKSWAP \
+       +@BUSYBOX_CONFIG_SWAPOFF \
+       +@BUSYBOX_CONFIG_SWAPON \
+       +kmod-zram
   TITLE:=ZRAM swap scripts
   PKGARCH:=all
 endef
 
 define Package/zram-swap/description
- A script to activate swaping on a compressed zram partition. This 
- could be used to increase the available memory, by using compressed 
+ A script to activate swaping on a compressed zram partition. This
+ could be used to increase the available memory, by using compressed
  memory.
 endef