treewide: replace AUTORELEASE with real PKG_RELEASE
[openwrt/openwrt.git] / package / system / zram-swap / Makefile
index 527800501b4e2fee4209d235179ddd2028b67fce..6e7e353f6fd768578036b8386dc8091d6ddbc7fd 100644 (file)
@@ -1,15 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2013-2021 OpenWrt.org
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zram-swap
-PKG_VERSION:=1.1
-PKG_RELEASE:=2
+PKG_RELEASE:=32
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -18,14 +14,20 @@ include $(INCLUDE_DIR)/package.mk
 define Package/zram-swap
   SECTION:=utils
   CATEGORY:=Base system
-  DEPENDS:=+kmod-zram +!(BUSYBOX_DEFAULT_MKSWAP||BUSYBOX_CONFIG_MKSWAP):swap-utils +!((BUSYBOX_DEFAULT_SWAPON||BUSYBOX_CONFIG_SWAPON)&&(BUSYBOX_DEFAULT_SWAPOFF||BUSYBOX_CONFIG_SWAPOFF)):block-mount
+  DEPENDS:= \
+       +@BUSYBOX_CONFIG_FEATURE_SWAPON_DISCARD \
+       +@BUSYBOX_CONFIG_FEATURE_SWAPON_PRI \
+       +@BUSYBOX_CONFIG_MKSWAP \
+       +@BUSYBOX_CONFIG_SWAPOFF \
+       +@BUSYBOX_CONFIG_SWAPON \
+       +kmod-zram
   TITLE:=ZRAM swap scripts
   PKGARCH:=all
 endef
 
 define Package/zram-swap/description
- A script to activate swaping on a compressed zram partition. This 
- could be used to increase the available memory, by using compressed 
+ A script to activate swaping on a compressed zram partition. This
+ could be used to increase the available memory, by using compressed
  memory.
 endef