olpc: cleanup config
[openwrt/openwrt.git] / package / udevtrigger / Makefile
index dd7a5396a454cbfd082fcd12a3fc0ef0b5a97a8b..99b28d20defe14bd40751d68592a63debf935430 100644 (file)
@@ -15,16 +15,17 @@ PKG_SOURCE:=udev-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/hotplug/
 PKG_MD5SUM:=320ccd2d0f4540d10e021bafa14f8985
 
-TAR_OPTIONS+=--transform='s,udev-$(PKG_VERSION),$(PKG_NAME)-$(PKG_VERSION),'
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/udev-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/udevtrigger
-       SECTION:=base
-       CATEGORY:=Base system
-       TITLE:=Small utility to request kernel devices events for coldplug
-       URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
-       MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
+  SECTION:=base
+  CATEGORY:=Base system
+  DEPENDS:=@LINUX_2_6
+  TITLE:=Small utility to request kernel devices events for coldplug
+  URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
+  MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
 endef
 
 define Build/Compile