treewide: Remove self from MAINTAINER entries
[openwrt/openwrt.git] / target / linux / ar7 / Makefile
index 3abf34edd281893bcd331571a164394c2934d2d8..ba40e508fcf76a22572787a1b2b3a5bba65177ab 100644 (file)
@@ -1,5 +1,5 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs jffs2 atm
-
-LINUX_VERSION:=2.6.25.1
+FEATURES:=squashfs atm low_mem
+SUBTARGETS:=generic ac49x
 
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
-       Build firmware images for TI AR7 based routers
+       Build firmware images for TI AR7 based routers.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= swconfig
+
 $(eval $(call BuildTarget))