treewide: Remove self from MAINTAINER entries
[openwrt/openwrt.git] / target / linux / ar7 / Makefile
index aeedaa2270e43c5e1718ffc2aa8625c6104336db..ba40e508fcf76a22572787a1b2b3a5bba65177ab 100644 (file)
@@ -9,18 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs jffs2 atm
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+FEATURES:=squashfs atm low_mem
+SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=2.6.37.6
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
-               kmod-acx-mac80211 swconfig hostapd
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
        Build firmware images for TI AR7 based routers.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= swconfig
+
 $(eval $(call BuildTarget))