ar71xx: ag71xx: init rings with GFP_KERNEL
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index d02504b618e4a9172ea0f30ae23f59eb937403f8..aa53b497355a2220c938db2abb535c13fca32793 100644 (file)
@@ -8,21 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR7240/AR913x/AR934x
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-SUBTARGETS:=generic nand
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=usbgadget source-only
+CPU_TYPE:=24kc
+SUBTARGETS:=generic tiny nand mikrotik
 
-LINUX_VERSION:=2.6.39.2
+KERNEL_PATCHVER:=4.14
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug swconfig
-
-define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x/AR934x based boards.
-endef
+       kmod-gpio-button-hotplug swconfig \
+       kmod-ath9k uboot-envtools
 
 $(eval $(call BuildTarget))