ar71xx: add device registration code for the AR934x NAND flash controller
[openwrt/openwrt.git] / target / linux / ar71xx / patches-3.3 / 612-ALL0315N-support.patch
index 9c054da5b43bf85d133a933b0f521f793d6a426c..7dedc04103008a80bd5e6588bdf06b482fab8e55 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-3.3.8/arch/mips/ath79/Kconfig
-===================================================================
---- linux-3.3.8.orig/arch/mips/ath79/Kconfig
-+++ linux-3.3.8/arch/mips/ath79/Kconfig
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
 @@ -38,6 +38,15 @@ config ATH79_MACH_ALL0258N
        select ATH79_DEV_LEDS_GPIO
        select ATH79_DEV_M25P80
@@ -18,11 +16,9 @@ Index: linux-3.3.8/arch/mips/ath79/Kconfig
  config ATH79_MACH_AP113
        bool "Atheros AP113 board support"
        select SOC_AR724X
-Index: linux-3.3.8/arch/mips/ath79/Makefile
-===================================================================
---- linux-3.3.8.orig/arch/mips/ath79/Makefile
-+++ linux-3.3.8/arch/mips/ath79/Makefile
-@@ -39,6 +39,7 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP)  += p
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -41,6 +41,7 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)               += route
  obj-$(CONFIG_ATH79_MACH_ALFA_AP96)    += mach-alfa-ap96.o
  obj-$(CONFIG_ATH79_MACH_ALFA_NX)      += mach-alfa-nx.o
  obj-$(CONFIG_ATH79_MACH_ALL0258N)     += mach-all0258n.o
@@ -30,10 +26,8 @@ Index: linux-3.3.8/arch/mips/ath79/Makefile
  obj-$(CONFIG_ATH79_MACH_AP113)                += mach-ap113.o
  obj-$(CONFIG_ATH79_MACH_AP121)                += mach-ap121.o
  obj-$(CONFIG_ATH79_MACH_AP136)                += mach-ap136.o
-Index: linux-3.3.8/arch/mips/ath79/machtypes.h
-===================================================================
---- linux-3.3.8.orig/arch/mips/ath79/machtypes.h
-+++ linux-3.3.8/arch/mips/ath79/machtypes.h
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
 @@ -20,6 +20,7 @@ enum ath79_mach_type {
        ATH79_MACH_ALFA_NX,             /* ALFA Network N2/N5 board */
        ATH79_MACH_ALL0258N,            /* Allnet ALL0258N */