kernel: remove obsolete kernel version switches
[openwrt/openwrt.git] / target / linux / armvirt / Makefile
index 2cf3820630b5895896a2b6f76d0122d094b4b140..73913f4a5b7b68ffc1d4bece93608093d7db4795 100644 (file)
@@ -1,20 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 BOARD:=armvirt
 BOARDNAME:=QEMU ARM Virtual Machine
 FEATURES:=fpu pci rtc usb
 FEATURES+=cpiogz ext4 ramdisk squashfs targz
-MAINTAINER:=Florian Fainelli <f.fainelli@gmail.com>, \
-       Yousong Zhou <yszhou4tech@gmail.com>
 
-KERNEL_PATCHVER:=4.9
+KERNEL_PATCHVER:=5.15
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))