kernel: remove obsolete kernel version switches
[openwrt/openwrt.git] / target / linux / armvirt / Makefile
index b91e932e688823d240b4074b72c247fc00e72ff3..73913f4a5b7b68ffc1d4bece93608093d7db4795 100644 (file)
@@ -1,28 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2016 Yousong Zhou <yszhou4tech@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=arm
 BOARD:=armvirt
 BOARDNAME:=QEMU ARM Virtual Machine
-FEATURES:=fpu pci rtc
+FEATURES:=fpu pci rtc usb
 FEATURES+=cpiogz ext4 ramdisk squashfs targz
-CPU_TYPE:=cortex-a15
-CPU_SUBTYPE:=neon-vfpv4
-MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
-
-KERNEL_PATCHVER:=4.4
 
-define Target/Description
-  Build images for QEMU ARM Virtual Machine
-endef
+KERNEL_PATCHVER:=5.15
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:=zImage
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))