Revert "cns3xxx: re-enable CONFIG_CPU_SW_DOMAIN_PAN"
[openwrt/openwrt.git] / target / linux / at91 / Makefile
index feb800dc0bb05d7542d681d88e49afa5e8a059cc..372bf177e4d3b4766263b18112fabbedbaad0ff2 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,13 +10,13 @@ ARCH:=arm
 BOARD:=at91
 MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs targz ext2 usb
-CPU_TYPE:=arm926ej-s
+FEATURES:=squashfs targz ext2 usb usbgadget ubifs
+SUBTARGETS:=legacy sama5d3
 
-LINUX_VERSION:=3.10.44
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-usb-ohci
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-eth-gadget
 
 $(eval $(call BuildTarget))