kernel: sfp: re-attempt probing for phy
[openwrt/openwrt.git] / target / linux / at91 / Makefile
index f8ca6f6be37d05b6021a28b6050b6d4d4e6011cb..6c1ba11c55109f416885b958dc9e2975627c8c37 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=AT91
-FEATURES:=squashfs usb
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com> \
+   Sandeep Sheriker <sandeep.sheriker@gmail.com>
+BOARDNAME:=Microchip (Atmel AT91)
+FEATURES:=ext4 squashfs targz usb usbgadget ubifs
+SUBTARGETS:=sama5 sam9x
 
-#LINUX_VERSION:=2.6.21.5
-LINUX_VERSION:=2.6.22.4
+KERNEL_PATCHVER:=4.14
 
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
+include $(INCLUDE_DIR)/target.mk
 
-include $(INCLUDE_DIR)/kernel-build.mk
+KERNELNAME:=zImage dtbs
 
-#include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-gadget-eth
 
-KERNELNAME:="uImage"
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))