uboot-at91: fix DTC command not found.
[openwrt/openwrt.git] / target / linux / at91 / image / sama5.mk
index d33a3986511e12c765eb2c00d94861aeb0dc4e5f..fd7a53421eb4f0895e1c615d5fc840a89196e0b8 100644 (file)
@@ -4,6 +4,7 @@ FAT32_BLOCKS:=$(shell echo \
   $$(($(AT91_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 define Build/at91-sdcard
+  $(if $(findstring ext4,$@), \
   rm -f $@.boot
   mkfs.fat -C $@.boot $(FAT32_BLOCKS)
 
@@ -11,29 +12,26 @@ define Build/at91-sdcard
 
   $(foreach dts,$(DEVICE_DTS), \
      mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb \
-        ::$(dts).dtb; \
-     mcopy -i $@.boot \
-        $(BIN_DIR)/u-boot-$(dts:at91-%=%)_mmc/u-boot.bin \
-            ::u-boot.bin; \
-     $(CP) $(BIN_DIR)/at91bootstrap-$(dts:at91-%=%)sd_uboot*/*.bin \
-         $(BIN_DIR)/BOOT.bin; \
-     mcopy -i $@.boot $(BIN_DIR)/BOOT.bin ::BOOT.bin;)
+        ::$(dts).dtb)
+
+  mcopy -i $@.boot \
+    $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
+    ::u-boot.bin
+
+  mcopy -i $@.boot \
+    $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
+    ::BOOT.bin
 
   ./gen_at91_sdcard_img.sh \
-      $(dir $@)$(IMG_PREFIX)-$(PROFILE_SANITIZED)-sdcard.img \
+      $@.img \
       $@.boot \
       $(KDIR)/root.ext4 \
       $(AT91_SD_BOOT_PARTSIZE) \
       $(CONFIG_TARGET_ROOTFS_PARTSIZE)
 
-  gzip -nc9 $(dir $@)$(IMG_PREFIX)-$(PROFILE_SANITIZED)-sdcard.img \
-         > $(dir $@)$(IMG_PREFIX)-$(PROFILE_SANITIZED)-sdcard.img.gz
+  gzip -nc9 $@.img > $@
 
-  $(CP) $(dir $@)$(IMG_PREFIX)-$(PROFILE_SANITIZED)-sdcard.img.gz \
-        $(BIN_DIR)/
-
-  rm -f $(BIN_DIR)/BOOT.bin
-  rm -f $@.boot
+  rm -f $@.img $@.boot )
 endef
 
 define Device/evaluation-sdimage
@@ -76,16 +74,28 @@ define Device/at91-sama5d4_xplained
 endef
 TARGET_DEVICES += at91-sama5d4_xplained
 
-define Device/wb50n
-  $(Device/evaluation-fit)
-  DEVICE_TITLE := Laird WB50N
-  DEVICE_PACKAGES := \
+define Device/at91-sama5d27_som1_ek
+  $(Device/evaluation-dtb)
+  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
+  KERNEL_SIZE := 6144k
+  $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d27_som1_ek
+
+ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+  define Device/wb50n
+    $(Device/evaluation-fit)
+    DEVICE_TITLE := Laird WB50N
+    DEVICE_PACKAGES := \
          kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
          kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
          kmod-leds-gpio
-  BLOCKSIZE := 128k
-  PAGESIZE := 2048
-  SUBPAGESIZE := 2048
-  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
-endef
-TARGET_DEVICES += wb50n
+    BLOCKSIZE := 128k
+    PAGESIZE := 2048
+    SUBPAGESIZE := 2048
+    MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+  endef
+  TARGET_DEVICES += wb50n
+ endif
+endif