kernel: use KCFLAGS for passing EXTRA_OPTIMIZATION flags
[openwrt/openwrt.git] / target / linux / ath25 / Makefile
index 03aa2a935596c67f611c8224bb65260e161b722d..ebbc9141d9fd317e55a4355b9571f34f63655f64 100644 (file)
@@ -1,25 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2006-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ath25
 BOARDNAME:=Atheros AR231x/AR5312
-FEATURES:=squashfs low_mem
-MAINTAINER:=Sergey Ryazanov <ryazanov.s.a@gmail.com>
+FEATURES:=squashfs low_mem small_flash
 
-KERNEL_PATCHVER:=4.4
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.10
 
 define Target/Description
        Build firmware images for Atheros SoC boards
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-basic-wolfssl kmod-ath5k swconfig kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))