kernel: use KCFLAGS for passing EXTRA_OPTIMIZATION flags
[openwrt/openwrt.git] / target / linux / ath25 / Makefile
index 86db43fd66f7a1b42b6906ee276e83cd72ac9b80..ebbc9141d9fd317e55a4355b9571f34f63655f64 100644 (file)
@@ -1,18 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2006-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ath25
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs low_mem small_flash
-MAINTAINER:=Sergey Ryazanov <ryazanov.s.a@gmail.com>
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.10
 
 define Target/Description
        Build firmware images for Atheros SoC boards
@@ -20,6 +18,6 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
+DEFAULT_PACKAGES += wpad-basic-wolfssl kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))