ath79: add support for TP-Link TL-WPA8630 v1
[openwrt/openwrt.git] / target / linux / ath79 / image / generic-tp-link.mk
index c2cda6b3df361d23000b2af1a86c89d0656981a9..fdc94b738a833a5bef281ae2e4021bf7164ea5c1 100644 (file)
@@ -500,6 +500,17 @@ define Device/tplink_tl-wdr4900-v2
 endef
 TARGET_DEVICES += tplink_tl-wdr4900-v2
 
+define Device/tplink_tl-wpa8630-v1
+  $(Device/tplink-8mlzma)
+  SOC := qca9563
+  DEVICE_MODEL := TL-WPA8630
+  DEVICE_VARIANT := v1
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  TPLINK_HWID := 0x86300001
+  SUPPORTED_DEVICES += tl-wpa8630
+endef
+TARGET_DEVICES += tplink_tl-wpa8630-v1
+
 define Device/tplink_tl-wpa8630p-v2
   $(Device/tplink-safeloader)
   SOC := qca9563