ath79: add support for Araknis AN-700-AP-I-AC
[openwrt/staging/mkresin.git] / target / linux / ath79 / image / generic.mk
index 2d595ccf633c507f06365ff3b09f6b845f27694d..769c0ee1dab531ed1b194592b5ea71073c573cb2 100644 (file)
@@ -343,6 +343,18 @@ define Device/araknis_an-500-ap-i-ac
 endef
 TARGET_DEVICES += araknis_an-500-ap-i-ac
 
+define Device/araknis_an-700-ap-i-ac
+  $(Device/senao_loader_okli)
+  SOC := qca9558
+  DEVICE_VENDOR := Araknis
+  DEVICE_MODEL := AN-700-AP-I-AC
+  DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct
+  IMAGE_SIZE := 11584k
+  LOADER_FLASH_OFFS := 0x220000
+  SENAO_IMGNAME := senao-generic-v1-an700
+endef
+TARGET_DEVICES += araknis_an-700-ap-i-ac
+
 define Device/arduino_yun
   SOC := ar9331
   DEVICE_VENDOR := Arduino