ath79: add support for ASUS RP-AC51
[openwrt/openwrt.git] / target / linux / ath79 / image / generic.mk
index 6fc844b4b2e427e6fb739f04fa3056be3f768347..8d059f367955c005b00ed75f06754f2292f01364 100644 (file)
@@ -389,6 +389,17 @@ define Device/asus_pl-ac56
 endef
 TARGET_DEVICES += asus_pl-ac56
 
+define Device/asus_rp-ac51
+  SOC := qca9531
+  DEVICE_VENDOR := ASUS
+  DEVICE_MODEL := RP-AC51
+  IMAGE_SIZE := 16000k
+  IMAGES += factory.bin
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct \
+       -swconfig
+endef
+TARGET_DEVICES += asus_rp-ac51
+
 define Device/asus_rp-ac66
   SOC := qca9563
   DEVICE_VENDOR := ASUS