kernel: bump 4.14 to 4.14.41
[openwrt/openwrt.git] / target / linux / ath79 / patches-4.14 / 0022-MIPS-ath79-drop-pci.c.patch
index 036bfc31c75d89f50c9db857a15c45cbf0a376eb..58ed122c68d7b7f79d8812d1f287bd52878bf9b7 100644 (file)
@@ -16,10 +16,8 @@ Signed-off-by: John Crispin <john@phrozen.org>
  delete mode 100644 arch/mips/ath79/pci.c
  create mode 100644 arch/mips/pci/fixup-ath79.c
 
-Index: linux-4.14.25/arch/mips/ath79/Makefile
-===================================================================
---- linux-4.14.25.orig/arch/mips/ath79/Makefile
-+++ linux-4.14.25/arch/mips/ath79/Makefile
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
 @@ -11,7 +11,6 @@
  obj-y := prom.o setup.o irq.o common.o clock.o
  
@@ -28,9 +26,7 @@ Index: linux-4.14.25/arch/mips/ath79/Makefile
  
  #
  # Devices
-Index: linux-4.14.25/arch/mips/ath79/pci.c
-===================================================================
---- linux-4.14.25.orig/arch/mips/ath79/pci.c
+--- a/arch/mips/ath79/pci.c
 +++ /dev/null
 @@ -1,285 +0,0 @@
 -/*
@@ -318,10 +314,8 @@ Index: linux-4.14.25/arch/mips/ath79/pci.c
 -
 -      return pdev ? 0 : -ENODEV;
 -}
-Index: linux-4.14.25/arch/mips/pci/Makefile
-===================================================================
---- linux-4.14.25.orig/arch/mips/pci/Makefile
-+++ linux-4.14.25/arch/mips/pci/Makefile
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
 @@ -29,6 +29,7 @@ obj-$(CONFIG_MIPS_PCI_VIRTIO)        += pci-vir
  #
  # These are still pretty much in the old state, watch, go blind.
@@ -330,10 +324,8 @@ Index: linux-4.14.25/arch/mips/pci/Makefile
  obj-$(CONFIG_LASAT)           += pci-lasat.o
  obj-$(CONFIG_MIPS_COBALT)     += fixup-cobalt.o
  obj-$(CONFIG_LEMOTE_FULOONG2E)        += fixup-fuloong2e.o ops-loongson2.o
-Index: linux-4.14.25/arch/mips/pci/fixup-ath79.c
-===================================================================
 --- /dev/null
-+++ linux-4.14.25/arch/mips/pci/fixup-ath79.c
++++ b/arch/mips/pci/fixup-ath79.c
 @@ -0,0 +1,21 @@
 +/*
 + *  Copyright (C) 2018 John Crispin <john@phrozen.org>